Get started with PHP-Fusion

Start a New Thread

Users Participated

  • Falk
    Post made: 1
  • mrmagill
    Post made: 2

  1. PHP-Fusion Support Forums
  2. PHP-Fusion 7 Support
  3. Upgrading issues

Upgrade 7.02.06 tp 7.02.07?

Please limit yourself to upgrading issues, not installation.

2 Replies 521 Views Last Updated on 3 months ago

mrmagill


Junior Member

#1

Posted 5 months ago

Having been the victim of malicious hacking in the past, I want to make sure my scripts are all up to the latest releases. However, when I examine the docs that come with 7.02.07 it only mentions how to upgrade from 7.01 - no mention of 7.02.06. I made sure I downloaded the GENUINE archive.... so, what is needed to get to the latest stable version? Am I missing something? If I am, if you would someone kindly explain?

I assume the new version must have some security fixes or updates, which is the main reason I wanted to do it.

Best to all -
Mark

Posts: 15

Joined: 23/07/2007

Falk


Super Admin

#2

Posted 5 months ago

Hi,
From 7.02.06 to 7.02.07 you just need to replace files and run the upgrade script in the administration.

Posts: 3562

Joined: 27/09/2005

mrmagill


Junior Member

#3

Posted 4 months ago

Thank you very much for that, one of the things I like about PHP Fusion so much is simplicity, but I could find nothing in the docs that specifically mentioned this step. I learned the hard way to keep things up to date when someone hacked an old version on one of my sites and destroyed it..

Mark

Merged on Dec 11 2016 at 00:19:09:
Well.... at first, something didn't seem to work right. I uploaded the files as usual, ran the upgrade script as usual, the screen refreshed, nothing appeared to have happened. Checking files, I see that the relevant files were replaced as expected, but the version number still says 7.02.06 instead of *.07.

The solution was simple - Go to "System Admin" and run the "Upgrade" button there. I'd forgotten about that. A minor database upgrade was needed and a file deleted. I'm mentioning this here for anyone else who may have an issue like this in the future. Version now reads 7.02.07 as it should. Thanks for the help, everyone.

Mark

Mark
Edited by mrmagill on 11-12-2016 00:19

Posts: 15

Joined: 23/07/2007

Jump to Forum:
6 users are online
0 member and 6 guests