Get started with PHP-Fusion

Start a New Thread

Users Participated

  • Kvido
    Post made: 1
  • Woody
    Post made: 5
  • Cupid
    Post made: 3
  • gh0st2k
    Post made: 3
  • douwe_yntema
    Post made: 4
  • sbshuib
    Post made: 1

  1. PHP-Fusion Support Forums
  2. PHP-Fusion 7 Support
  3. System Administration - 7

Users log out after 1 click

All questions about the system management and it's settings

16 Replies 6,169 Views Last Updated on 2 months ago

Cupid


Member

#1

Posted 6 years ago

After a user signs in on my page and click on a different part of the site it makes them log in again.

For example, if you log in, then try to go to the forum, it asks you to log in again. They won't stay logged in.

here is my site
http://vivalavolt...

EDIT: I removed the Test account since it is not needed at this time.
Edited by Cupid on 04-11-2011 15:21

Posts: 96

Joined: 16/02/2008

gh0st2k


Member

#2

Posted 6 years ago

Check your config.php and check this line, it must look like this:

define("COOKIE_PREFIX", "fusion94821_");

This is just an example, you can change fusion94821 to whatever you want.

If it is not working after clearing your cookies and relogin, then please reupload your files in the includes/classes folder!

You're using v7.02.03?
Edited by gh0st2k on 04-11-2011 10:31

Posts: 131

Joined: 23/11/2008

Cupid


Member

#3

Posted 6 years ago

PLease explain something for me. Whatever I want? I"m running multiple sites. Do they have to be the same for all multisites or different?

I did that and it just made my site inaccessible.
Edited by Cupid on 03-11-2011 22:10

Posts: 96

Joined: 16/02/2008

gh0st2k


Member

#4

Posted 6 years ago

I disabled smilies... you can use other chars / numbers. Can you show me your actual config.php (only the part with the cookie prefix)?

When you're using multisite only with subdomains, then open your database, go the the table settings and change site_host to ".vivalavoltz.com" (remove " please). All your cookies will be available on all subdomains. There are still some issues with the domain cookies...
Ex Senior Dev.

Posts: 131

Joined: 23/11/2008

Cupid


Member

#5

Posted 6 years ago

Yeah thanks a lot. I actually poked around on some older threads and tried that. I had my domain set wrong. Thanks for your help. I appreciate it.

Posts: 96

Joined: 16/02/2008

gh0st2k


Member

#6

Posted 6 years ago

As far as I can see that was not the problem, but okay Wink
I checked your site again, the cookie name is now correct and the domain is the same like two days before.

But I'm happy that it is working now Smile
Ex Senior Dev.

Posts: 131

Joined: 23/11/2008

sbshuib


Newbie

#7

Posted 3 years ago

hi all,
just to ask. i just install PF 7.03, and still faced same issue since using 7.02. The issue is, always get logout whenever viewing different page. Anything can be sort out this issue? thank you so much. help needed.. :-(

my site use for intranet.
http://127.0.0.1

Posts: 2

Joined: 10/02/2015

Woody


Junior Member

#8

Posted 3 months ago

After a user signs in on my page and click on a different part of the site it makes them log in again.

For example, if you log in, then try to go to the forum, it asks you to log in again. They won't stay logged in.


I'm using 7.02.07 full and my site was working fine then started doing the same thing as in quote. I tried the clear cookies and change site link in myphpadmin and aslo tried to edit the config cookies. Now what can i do? https://www.north...nbiker.com

Posts: 46

Joined: 26/09/2007

douwe_yntema


Senior Member

#9

Posted 2 months ago

When did it start?

Check the following settings in your settings table with phpmyadmin for https protocol and Linus hosts:

siteurl https://www.yoursite.com/
site_protocol https
site_host www.yoursite.com
site_port (empty for standard ports)
site_path /

Posts: 334

Joined: 31/03/2013

Woody


Junior Member

#10

Posted 2 months ago

it has happened twice so far and it is a fresh install

Posts: 46

Joined: 26/09/2007

douwe_yntema


Senior Member

#11

Posted 2 months ago

Remove /neb after siturl in your settings

Posts: 334

Joined: 31/03/2013

Woody


Junior Member

#12

Posted 2 months ago

ok did that and cleared cash etc and still doing it hmmm what to do next?
I have another site that is working just fine same host and all.

Posts: 46

Joined: 26/09/2007

douwe_yntema


Senior Member

#13

Posted 2 months ago

Currently I am out of options, so I did a search on this forum an give you some hints

https://www.php-f...post_17945

What theme are you using? Could be a theme problem. Try change to gilette theme.

Posts: 334

Joined: 31/03/2013

Woody


Junior Member

#14

Posted 2 months ago

yup i tried to change theme to gilette and same thime ...sent you a pm

other site same host same theme
https://www.odsclan.net

working fine so far
Edited by Woody on 16-07-2017 19:14

Posts: 46

Joined: 26/09/2007

douwe_yntema


Senior Member

#15

Posted 2 months ago

From post #10 picture, try change site path to /

Posts: 334

Joined: 31/03/2013

Woody


Junior Member

#16

Posted 2 months ago

huh that worked tx
Edited by Woody on 17-07-2017 02:29

Posts: 46

Joined: 26/09/2007

Kvido


Senior Member

#17

Posted 2 months ago

For the https at https: phpfusion.com in version 9.0 we have this way, it works smoothly:

.... Now I realized you were going to version 7.03. I do not know, we have no version of 7.xx.
Edited by Kvido on 17-07-2017 07:24

Posts: 448

Joined: 01/08/2007

Jump to Forum:
5 users are online
0 member and 5 guests