Get started with PHP-Fusion

Start a New Thread

Users Participated

  • Kvido
    Post made: 4
  • Chan
    Post made: 2
  • Kamillo
    Post made: 1
  • zizub
    Post made: 4

  1. PHP-Fusion Support Forums
  2. PHP-Fusion 9 Support
  3. SEO & SEF

SEO update

Questions related to 9īs Search Engine Optimizations and Search Engine Friendly URLs API

10 Replies 1,467 Views Last Updated on 6 months ago

Chan


Super Admin

#1

Posted 7 months ago

I've made increment on Github for 9.02 on all fixes on SEO I could find last hour. I'm not sure if I have covered it all or it will have bugs. But be sure to check it out. There are many faulty issues that has been fixed.

Posts: 3392

Joined: 25/09/2007

Kamillo


Senior Member

#2

Posted 7 months ago

Let us make sure, that without login:
- links in forums are not visible by default
- in comments as well
- profile and links as well

That is bad seo, that takes spammers to make thaire posts/profile indexed.

Posts: 211

Joined: 05/10/2008

Chan


Super Admin

#3

Posted 7 months ago

If I'm not wrong, Links are handled by bbcode. both url and autolink. For autolink, it's no index by default, non settings. For url, you can control.via ACP.

See the new parse_textarea - the all in one parse function, set to TRUE in bbcode parsing and autolink should kick in. They are hardcoded.

Posts: 3392

Joined: 25/09/2007

Kvido


Senior Member

#4

Posted 7 months ago

Hello!
Administration (Artemis) / SystemAdmin / Permalinks - SEO does not display settings, see. picture.

Merged on Dec 13 2016 at 13:43:03:
Update Git December 13, 2016 - 12:10
Permalinks are well displayed, see image and work. SEO links OK!

Just a mistake. HomePage on the header frame contains the code (??).
Edited by Kvido on 13-12-2016 13:43

Posts: 440

Joined: 01/08/2007

zizub


Member

#5

Posted 7 months ago

I have like all is good. Debug mode CEOs reveals red:
1. blogs / 3 / uidzhi.-prokljatie-doski-d-javola: No matching Alias found.
2. blogs / 3 / uidzhi.-prokljatie-doski-d-javola: No matching Alias Pattern found.

Posts: 92

Joined: 02/05/2012

Kvido


Senior Member

#6

Posted 7 months ago

In your .htaccess commented:
# Options-Indexes

Posts: 440

Joined: 01/08/2007

zizub


Member

#7

Posted 7 months ago

In your .htaccess commented:
# Options-Indexes
- by Kvido

My htaccess file looks like this:
# Force utf-8 charset
AddDefaultCharset utf-8

# Security
ServerSignature Off

# Secure htaccess file
<Files .htaccess>
order allow,deny
deny from all
</Files>

# Protect config.php
<Files config.php>
order allow,deny
deny from all
</Files>

# Block Nasty Bots
<IfModule mod_setenvifno.c>
SetEnvIfNoCase ^User-Agent$ .*(craftbot|download|extract|stripper|sucker|ninja|clshttp|webspider|leacher|collector|grabber|webpictures) HTTP_SAFE_BADBOT
SetEnvIfNoCase ^User-Agent$ .*(libwww-perl|aesop_com_spiderman) HTTP_SAFE_BADBOT
Deny from env=HTTP_SAFE_BADBOT
</IfModule>

# Disable directory listing
Options -Indexes

Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
# Let PHP know mod_rewrite is enabled
<IfModule mod_env.c>
SetEnv MOD_REWRITE On
</IfModule>
RewriteEngine On
RewriteBase /fusion9/
# Fix Apache internal dummy connections from breaking [(site_url)] cache
RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
RewriteRule .* - [F,L]
# Exclude /assets and /manager directories and images from rewrite rules
RewriteRule ^(administration|themes)/*$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteCond %{REQUEST_URI} !^/(administration|config|index.php)
RewriteRule ^(.*?)$ index.php [L]
</IfModule>

Posts: 92

Joined: 02/05/2012

Kvido


Senior Member

#8

Posted 7 months ago

IfModule mod_rewrite.c should be like this.
Try, if it helps.
Code Gist: Download source  

# Disable directory listing
# Options-Indexes

#Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
   # Let PHP know mod_rewrite is enabled
   <IfModule mod_env.c>
      SetEnv MOD_REWRITE On
   </IfModule>
   RewriteEngine On
   RewriteBase /
   # Fix Apache internal dummy connections from breaking [(site_url)] cache
   RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
   RewriteRule .* - [F,L]
   # Exclude /assets and /manager directories and images from rewrite rules
   RewriteRule ^(administration|themes)/*$ - [L]
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteCond %{REQUEST_FILENAME} !-l
   RewriteCond %{REQUEST_URI} !^/(administration|config|index.php)
   RewriteRule ^(.*?)$ index.php [L]
</IfModule>

Posts: 440

Joined: 01/08/2007

zizub


Member

#9

Posted 6 months ago

Kvido - Thanks for the answer. I have tried the your option # Options but I have it not work. I'm testing on XAMPP localhost. When you try to open the site, I get a redirect to a page XAMPP __http://localhost/dashboard/

I little knowledge of SEO links. But maybe this error is uncritical, if she not visible for website visitors, turning off her in the admin panel / settings permalinks / SEO Enable debug mode:?

When you attempt to Disable SEO debug mode: / in, Permanent Links parameters, I got an error message - An error has occurred. It happens rarely. The message in the error log both in the this topic - http://www.php-fusion.co.uk/forum/viewthread.ph...ost_200907
Edited by zizub on 15-12-2016 20:18

Posts: 92

Joined: 02/05/2012

Kvido


Senior Member

#10

Posted 6 months ago

@zizub
Hello!
1 / operation lolcalhost XAMPP is quite unreliable, but it should work.
2 / The version of PHP and MySQL you use, it is important to PHP should be more than the version of PHP 3.5
3 / I'm sending you a private message via PM my .htaccess. Copy this file and see.
Edited by Kvido on 16-12-2016 13:44

Posts: 440

Joined: 01/08/2007

zizub


Member

#11

Posted 6 months ago

Kvido - Hello! I replied to the PM.

Posts: 92

Joined: 02/05/2012

Jump to Forum:
12 users are online
0 member and 12 guests