Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
Posted by Last replied by Chan 3 months ago

Site Update/Maintenance: User Feedback & Support

How do you like the progress on the site updates and features? If you have any comments, or feedback, or questions, kindly drop us a holler.

Thank you.

Management Team.
410 views 0 votes
1 post
Posted by Falk Last replied by Falk 2 years ago

Upgrading v7 Infusions to v9

In infusion.php you will need to add ,
Code
$settings = fusion_get_settings();

This might also be required in other places depending on the complexity of your infusion.

In this section ,
Code
$inf_adminpanel[] = array(

Add, under rights page 5 as follows. Do not miss the , on the rights line.
Code
   
"rights" => "DEMO",
"page" => 5


page 5 means that it will be listed under Infusions, 1-4 is the other tabs.

$inf_newtable[1] etc can all be striped of the number , like :
$inf_newtable[] row1;
$inf_newtable[] row2;
etc
The system will enumrate automatically.

TYPE = MyIsam should always be ENGINE = MyISAM,
preferably like,
Code
ENGINE=MyISAM DEFAULT CHARSET=UTF8 COLLATE=utf8_unicode_ci";

Since we use UTF8 in 9.

You need to replace all
with openform(); and all
with closeform();
Since many old infusions use formaction, this is how you would make it work with openform();

Code
$formaction = "".INFUSIONS."yourinfusion/target.php";
echo openform('inputform', 'post', $formaction, array('enctype' => 1,'class' => 'm-t-20'));

If you do not want to use the new form system you can manually insert tokens like,

Code
               // Token data
               $options['form_id'] = "12345678";
               $options['max_tokens'] = "1";
               $options['remote_url'] = fusion_get_settings('site_path').'infusions/myinfusion/post.php';
               $token = \Defender\Token::generate_token($options['form_id'], $options['max_tokens'], $options['remote_url']);

               // Begin Form
               echo "
\n";
               echo "\n";
               echo "\n";
               
               // Form content as usual
               
               echo "
\n";


Please note that any MySQL errors will halt the Infuse as a whole, generic upgrade lines that fail or generic table modification attempts on non existing tables will result in a failure.
1635 views 0 votes
1 post
Posted by Chan Last replied by Chan 2 years ago

BETA TESTERS: Understanding the Bug Reader - Please Read!

1291 views 0 votes
1 post
Posted by Craig Last replied by Craig 8 years ago

7.02 User Felds API Guide

Hi,

Just in case some of you talented coders have not yet seen the guide how to use the new 7.02 User Fields API, you can download it from the attachment here.

It might help addons developers understand how User Fields now work.

Happy Coding, I look forward to seeing some nice new fields!!
3730 views 0 votes
1 post
Posted by Last replied by helmuth 7 days ago

Register at this site not possible

It has ben reported on the Danish site that it is not possible to register at this site !!!

http://php-fusion.dk/forum/viewthread.php?thread_id=19486&pid=123208#post_123208
12 views 0 votes
1 post
Posted by Last replied by RobiNN 18 days ago

Atom9 - Ignition Pack

www.php-fusion.co.uk/infusions/marketplace/uploads/image/atom9-starcity.png


Atom9 is a package of 3 themes.

Note: to change theme you need to install widget.

-- View this Item --
66 views 0 votes
1 post
Posted by Last replied by djdandi 18 days ago

The news editor can not see my images

I write news in the editor of TinyMCE Editor and send pictures to news via the administration / images.php page for news. Unfortunately, TinyMCE editor can not see my pictures - why?
When will it be fixed?

i.postimg.cc/ZKHF73Y2/1.png

i.postimg.cc/c4CrW8MV/2.png
76 views 0 votes
1 post
Posted by helmuth Last replied by helmuth 22 days ago

edit profile social accounts youtube

No matter what you insert in the youtube field it points at one's own profile here at this site
62 views 0 votes
1 post
Posted by ikandi Last replied by ikandi 28 days ago

YouTube videos in BBCode

I'm not really a fan of BBCode in PHP Fusion.
It doesn't follow the same coding logic as the majority of the site, and IMHO, needs to be entirely overhauled or thrown out.
From what I can see, Bootstrap is not currently supported for BBCode within PHP Fusion 9. which makes it difficult to use Responsive div/class types within things like the forum and comments.

On other pages such as articles and news, I can use code for images and videos and make them responsive by using code such as:

Code
LABEL


Code


Are there any plans to bring Bootstrap functionality into BBCode Land?

thanks.
362 views 0 votes
1 post
Posted by djdandi Last replied by djdandi 1 month ago

Mass image upload in PA

Hello, can you add the ability to send several pictures at a time to news, article, blog etc. on the website www ..... / administration / images.php
Currently you can send one picture and this is a bit of a nuisance.
i.postimg.cc/5t1JCzNX/imagess.png
97 views 0 votes
1 post
Posted by Jamesarthur26 Last replied by Jamesarthur26 2 months ago

Help: Moving my page

Hi all,

Since like a week I'm thinking about moving my page to php-fusion.
My page is an SQL tutorial, wiec videos ect. I'm on a wordpress right now. Would you recommend on moving to php-fusion? I'm a newbie and WordPress is really easy, will I be fine on php-fusion? All comments welcome.

Oh and btw. How much would cost a transfer? I mean to pay someone who will be able to do it.
Jason
118 views 0 votes
1 post
Posted by Wanabo Last replied by Wanabo 2 months ago

Signature Rules before showing

I joined a site today powered by XenForo.

I like the signature rules feature. As a matter of fact I modded my v7 with a simple mod to show only signatures when the post count is greater than 5.

But it would be nice to have something like below in v9!
And all customizational of course.

Signature Rules:

Before you can modify your signature, you must have passed the following conditions:

The number of posts you have created must exceed: 10 (Yours: 1)
The number of Likes you've received must exceed: -1 (Yours: 0)
The Like:Post Ratio must exceed: -1% (Yours: 0%)
The number of days you have been registered must exceed: 1 (Yours: 0)
133 views 0 votes
1 post
Posted by terrylzh Last replied by terrylzh 2 months ago

unable to change admin passwords

hi I am having problems in changing admin password for all administrators.

all admin accounts is unable to change their admin passwords.

there is no error messages when keying in new admin password in edit profile but the new admin password that was entered is simply not being updated.

any advice please
132 views 0 votes
1 post
Posted by michealgrzz Last replied by michealgrzz 3 months ago

Got Registration Error

I have been using phpfusion for about 2 months now without any problems. However today I had members recieving the following error

Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/australi/public_html/includes/smtp_include.php on line 106

Warning: fsockopen() [function.fsockopen]: unable to connect to australianonlinepokerleague.com:25 in /home/australi/public_html/includes/smtp_include.php on line 106

I have not changed any settings.
The only thing I can see is that my webhost changed servers a few days ago. I have seen posts about this problem and have tried what is mentioned but no luck.
I have emailed the webhost but am still waiting for a reply to see if the port has changed.
Is there anything elseI can do at this stage?
203 views 0 votes
1 post
Posted by ikandi Last replied by ikandi 4 months ago

Systems Tag Panel (for v9.0)

Glad to see PHP9 is coming together well. It still seems though that the uptake from v7.02 is still slow. Hopefully that will change in time.

This time I have a query about the use of Tags within PHP Fusion.

Like many, I deployed the use of the Tags System Panel infusion, as created by user/developer Hobbyman. A great infusion, where tags could be integrated onto your site without the modification of core files.

On my previous 7.02 system, it worked like a charm, and I would like to add it into the 9.0 system, but alas, using the same code it doesn't quite work.

Unfortunately, it would seem that Hobbyman is no longer involved in coding anymore, according to his website. He stopped around February this year.

Is anyone familiar with the Systems Tag Panel that he wrote?

I'm very keen to re-establish it for my site. I would even pay someone to work on the code, which doesn't appear to be too onerous - but beyond me I'm afraid.. lol

Thanks.

Ikandi
255 views 0 votes
1 post
Posted by Grimloch Last replied by Grimloch 4 months ago

ColorBox Stops Working

My whisperwillow site is hosted with A2 Hosting. Since they now offer the ( Let's Encrypt ) secure/https solution for free I have done that on my site. After doing so I found out that the colorbox image zoom function no longer works. Any ideas why and how to fix?
224 views 0 votes
1 post
Posted by ikandi Last replied by ikandi 5 months ago

Using Smileys - Forum Posts and Comments

Hi there everyone,

My first post here as a PHP 9.0 user.

I need some assistance with some functionality issues with my recently migrated PHP 9.0 Site.
It's looking good btw guys, a lot of work has gone into PHP9, so well done.

My site is using the Bootstrap theme by default. I preferred this to the other two, as I was recently using the Bootstrap 3 theme in DokuWiki, which looked quite beautiful.
There are a number of teething issues I've identified; I'll create separate threads for these as I go.

The first one is to do with Smileys. I have loaded up quite a few additional smileys on my site, well over the number of originals which shipped with the PHP9 download.

When creating forum posts, or replying to Comments, if you use Smileys, the Smileys Pop Up Box from the Editor disappears behind the forum post and/or comment window/screen. You can't get access to them. Sometimes, they will overflow underneath the post/comment window/screen, which remains in the foreground.
I notice it's the same for this site too.

Sometimes the Footer script on the page also interferes with smileys too. You try to click on a smiley, but a link like the GNU Affero GPL Link gets in the way.

This makes it frustrating for users to be unable to access smileys visually/physically. The way around it is to memorize the shortcodes of the smileys and put it in a 'cheat-sheet', but that defeats the purpose of having smileys in the Forum/Comments Editor.

I'm just wondering if someone could look at this when there is an opportunity.
I've added an attachment to describe/ visualize the issue.

Thanks.

Ikandi
294 views 0 votes
1 post
Posted by sadamyne Last replied by sadamyne 5 months ago

Infusions after upgrade

Hi,

I upgrade from version 7 to an early version 9 and now to the last version.
After upgrade my infusions admin panel is empty.
Is this normal?
Thanks in advance
244 views 0 votes
1 post
Posted by Jamesarthur26 Last replied by Jamesarthur26 5 months ago

Photogallery sub albums

Is there a way to make sub albums for photogallery? Not the image ones but with text and so they will show up in the same page
example:
Category1:
Image Image image
Category2:
Image image image

^ So it would display like this? No images just text
|| I know theres a mod but its with images and i cant really edit it to make it likes this :( so help me please?
266 views 0 votes
1 post
Posted by Grimloch Last replied by Grimloch 6 months ago

Request: Help with PM functions

I will try to explain my problem w/o a lengthy dissertation. My Newsletters infusion works perfectly fine but I decided to add a 'pm to admin' function when subscriptions are set to 'public'. The actual public subscription works fine but I cannot get the script to send a pm to the admin no matter what I try. Here is the code I'm using at the moment and BTW this code works perfectly when my Site Statistics panel sends a birthday pm to a user.

Code
if (isnum(isset($_REQUEST['id'])) AND isset($_REQUEST['activate'])) {
   echo "
\n";
   $get_vc = dbquery("SELECT * FROM ".DB_NEWS_LETTER_SUBS." WHERE nl_sub_id='".$_REQUEST['id']."'");
   $get_vca = dbarray($get_vc);
   $get_vcr = dbrows($get_vc);
   if ($get_vcr != 0) {
      if ($get_vca['nl_sub_stat'] == 0) {
         $get_vn = dbquery("SELECT * FROM ".DB_NEWS_LETTER_VALIDATE." WHERE validate_code='".$_REQUEST['activate']."'");
         $get_vna = dbarray($get_vn);
         $get_vnr = dbrows($get_vn);
         if ($get_vnr != 0) {
            $result = dbquery("UPDATE ".DB_NEWS_LETTER_SUBS." SET nl_sub_stat='1' WHERE nl_sub_id ='".$_REQUEST['id']."'");
            $result = dbquery("DELETE FROM ".DB_NEWS_LETTER_VALIDATE." WHERE validate_code='".$_REQUEST['activate']."'");

// send pm to site admin
$pm_send = dbquery("SELECT nl_sub_id, nl_sub_mail, nl_sub_name, nl_sub_stat FROM ".DB_NEWS_LETTER_SUBS." WHERE nl_sub_stat='1' AND nl_sub_id='".$_REQUEST['id']."'");
if (dbrows($pm_send) != 0) {
require_once INCLUDES."infusions_include.php";
   while($data = dbarray($pm_send)) {
      $sendr = $data['nl_sub_mail'];
      $pnam = $data['nl_sub_name'];
      $recvr = 1;
   $sndit = ($locale['nl_498']."".$pnam.$locale['nl_499']);
send_pm($recvr, $sendr, $locale['nl_497'], $sndit);
   }
}
// end pm send


I have tried the $recvr variable as ($settings['siteemail'] and also just "webmaster@whisperwillow.com") . I realize that code taken out of context can be hard to interpret/follow and I will post the entire script if needed. Right after the code: if (dbrows($pm_send) !=0) if I do this: echo dbrows($pm_send); exit; .. it stops the script and prints a 1 to the screen so I know it's doing the dbquery and getting a result. Any help would be appreciated very much. I am using Fusion 7.02.07

Merged on 05/28/2018:
OK ! I figured out why it won't work ! The '$sendr' variable which gets input to 'infusions_include.php' as the '$from' variable, is a public user who has an email address but NO system user id. I don't know how to fix that except maybe using one of my alternate logins as the sender. That should work.
284 views 0 votes
1 post
Community Details
PHP-Fusion CMS Community
37.7k
Active Members
23
Online

The official English language support forum for PHP-Fusion CMS

Popular Contributors
  • helmuth
    helmuth
    4
  • Falk
    Falk
    4
  • iceman50
    iceman50
    3
  • Oskman
    Oskman
    2
  • Chan
    Chan
    1