Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

[Solved] SQL trouble

Searching did not solve my problems, so perhaps one of you can!

My webhoster migrated from ensim to plesk and now parts of my websites are not displayed!:@

After studying panels etcetera I found that additional \ (BACKSLASH) was inserted in the code.

Example:

Quote

google_color_link = \"0075EF\";
google_color_text = \"000000\";
google_color_url = \"008000\";


This happens also in the site description and other places.

According to my hoster this fault could be related to the difference in PHP versions. The ensim environment used PHP version 4 end the plesk environment uses PHP version 5.

Experimented with restoring backups. PHPMYadmin restore possible but fault still there. Restore function in PHP-Fusion not working anymore!:(


Questions:
1. Anybody knows / recognizes the backslash problem and has a solution!
2. Why can't I use internal restore function from Fusion?


I know I could restore some of the code by checking all the panels, but as this is just the first website and more will follow.
UPDATE

Quote

2. Why can't I use internal restore function from Fusion?[/b][/color]

Strangely the directory * administration/db_backups/ was not cmodded to 777. [FIXED]

But now when I restore a backup in PHP-Fusion the complete database is erased!!!:o Even when restoring a fresh backup!

Quote

I know I could restore some of the code by checking all the panels, but as this is just the first website and more will follow.

This does not work! For example the welcome text wil not show no matter what I put in there. And when I enter a ' or " this is replace by \' or \" . :@
Sounds like a gpc_quotex issue to me, check phpinfo and see what magic_qoutes_gpc and magic_qoutes_runtime are set to.

Quote

Digitanium wrote:
Sounds like a gpc_quotex issue to me, check phpinfo and see what magic_qoutes_gpc and magic_qoutes_runtime are set to.


Found these settings in PHPinfo.

Configure Command '--enable-magic-quotes'

and

magic_quotes_gpc Off Off
magic_quotes_runtime On On
magic_quotes_sybase Off Off


Is this good or bad!!

The website in question is http://www.kiesverstandig.eu
Update!

Digitaniums remark about quotes was correct. Mailed my hoster to change the setting from magic_quotes_runtime On to Off. Now it seems OK! :)

A Big Thank You to you Digitanium!;)

Its magic_quotes_runtime, should be off imo, ask your host to consider turning off runtime but turn on quotes_gpc

magic_quotes_gpc Off Off
magic_quotes_runtime On On

To

magic_quotes_gpc On On
magic_quotes_runtime Off Off
Yes after magic_quotes_runtime was set to off al was ok!

I have 2 domains, both were hosted on a ensim environment. I have to migrate because the ensim dashboard is malfunctioning.

A.t.m only kiesverstandig.eu is migrated so I could check the settings on my other properly working domain gebruikers.eu. However on this domain magic_quotes_gpc is set to off. Of course I could ask the hoster to turn on magic_quotes_gpc, but after googling about this subject many preferred magic_quotes_gpc to be turned Off.

So for the sake of experiment I am willing to ask my hoster to turn magic_quotes_gpc On, but what is there to gain with this setting??
Thread Information
Author
Replies
7 posts
Views
3,135 times
Last Post
Last updated on 13 years ago
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.