Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Php include dont work in php fusion?

im trying to have this code in my panel for a feed of latest posts on my IPB forums:

CodeDownload  
openside("Latest Posts");
echo '<html>
<body>
<?php include("http://1191adb.com/forums/latest_posts.php"); ?>
</body>
</html>';
closeside();



But all i get is a blank panel. No error, nothing. I tried it without the html and body tags but still doesnt work.
iframe works obviously but i cant do that because the links will also open in that frame.
Help please :(
CodeDownload  
Parse error: syntax error, unexpected '<' in /home/gamingte/public_html/1191adb/ac/side_right.php(43) : eval()'d code on line 1



hmm....
Try this, I did a quick test and it seemed to work ok...

CodeDownload  
openside("Latest Posts");
include 'http://1191adb.com/forums/latest_posts.php';
closeside();




Edit: sorry chankarwing, we posted at the same time
CodeDownload  

Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/gamingte/public_html/1191adb/ac/side_right.php(43) : eval()'d code on line 4

Warning: include(http://1191adb.com/forums/latest_posts.php) [function.include]: failed to open stream: no suitable wrapper could be found in /home/gamingte/public_html/1191adb/ac/side_right.php(43) : eval()'d code on line 4

Warning: include() [function.include]: Failed opening 'http://1191adb.com/forums/latest_posts.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/gamingte/public_html/1191adb/ac/side_right.php(43) : eval()'d code on line 4



Im getting this for both!
And god damn it, i swear to god HobbyMan's should have worked. Urgh!
Yes, this is a server problem because I tried it on one site and it worked..

www.hobbysites.net/mods/latestposts2.jpg

and on another site and it didn't...

www.hobbysites.net/mods/latestposts1.jpg

and they're both by the same host [though on different servers] and both v6.00.15
My hoster said that half of his sites use include so that's cant be!

Gah i gotta get this to work really badly.
No, nothing works.
It does seem like a server issue, but my hoster, who is being hosted by a host and he hosts my site on his like..."part" of the host, says that a few of his own sites use the include function and it works fine..weird.

Quote

chankarwing wrote:
You can try:......


His problem is he want's to link to an outside source... [http://1191adb.com/forums/latest_posts.php], which is an invision forum and not php-fusion and include is disabled by his host.
Im getting a thought that it could be possibly only disabled for my folder on the host?
I cant, it has to be in the IPB folder. Its a mod i downloaded which consists of only one php file, that one, so its meant to be there.
i have to php fusion sites.

one of them is in pop/
the other is in ac/
the forums are in forums/
all of these folder are in the root folder of the website.
i want the latest posts to display both in pop and ac sites.
Thank you.
God.
It works!!!
Thanks TammyK!
Thread Information
Author
Replies
12 posts
Views
1,540 times
Last Post
Last updated on 11 years ago
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.