Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Can't use "$site = $_GET['site'];" without "PHP-Notice"

Hey~

I'm sorry if i'm posting this into wrong forums... = /

Well~ I have a Problem by using "$site = $_GET['site'];" on my Costum Sites. I want to use this in PHP-Fusion:

my_own_site.php?own_id=10&site=meow

But well... if it goes just this:

my_own_site.php?own_id=10

It show's the following Notice:

Notice: Undefined index: site in ***

But when im using my Costum Site without including it into PHP-Fusion ... there is no PHP-Notice like that... = /

I've included this @ the top:

CodeDownload  
require_once "maincore.php";
require_once THEMES."templates/header.php";



And the following @ the bottom:

CodeDownload  
require_once THEMES."templates/footer.php";



So... I think the PHP-Notice show's only because of PHP-Fusion... is it because of a funtion or do I have to use this: "$site = $_GET['site'];" on another way...?! ^^

Thx 4 every help~ :3
PHP-Fusion, shows evrything - also small notices... :)

Try this:
CodeDownload  
if (isset($_GET['site']) $site = $_GET['site'];

Hey, BIG THX, works well! ;3
Notice fixed & Thread locked.
Thread Information
Author
phpfjs
Replies
4 posts
Views
1,474 times
Last Post
Last updated on 11 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Josso, Basti, phpfjs