Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

6.01.15 to v7 - comments table not exist error

Hi just done a test upgrade of one of my sites to version 7

one issue so far

www.test2.nippershair.co.uk

says on home page :

Quote

Table 'nipperstest2.comments' doesn't exist


old site is at www.nippershair.co.uk

the comments table does exist in the databse??? although it is empty

help

Ian
anyone got any ideas for this ?
Really need to resolve it as it is for a customer's site...
Should I raise it in the support system?
are you not using a prefix?
I am indeed and as you can see from the site it can read most tables and display content ok?

fusion_nippers_comments table exists and is empty

CodeDownload  
    Field     Type     Collation     Attributes     Null     Default     Extra     Action
   comment_id    mediumint(8)       UNSIGNED    No       auto_increment    Browse distinct values    Change    Drop    Primary    Unique    Index    Fulltext
   comment_item_id    smallint(5)       UNSIGNED    No    0       Browse distinct values    Change    Drop    Primary    Unique    Index    Fulltext
   comment_type    char(2)    latin1_swedish_ci       No          Browse distinct values    Change    Drop    Primary    Unique    Index    Fulltext
   comment_name    varchar(50)    latin1_swedish_ci       No          Browse distinct values    Change    Drop    Primary    Unique    Index    Fulltext
   comment_message    text    latin1_swedish_ci       No          Browse distinct values    Change    Drop    Primary    Unique    Index    Fulltext
   comment_datestamp    int(10)       UNSIGNED    No    0       Browse distinct values    Change    Drop    Primary    Unique    Index    Fulltext
   comment_ip    varchar(20)    latin1_swedish_ci       No    0.0.0.0    

have just tried with new test site

so created test3 domain
created new database and copied v6 db to test3 site
copied v6 files to test3 site
made it work as v6.01.15

then followed upgrade
i.e.
a. copied upgrade.php to administration
b. logged in as admin and ran UPGRADE in system admin
c. followed 4 steps clicking next until it said database upgrade complete
d. ftp'd all contents of "files" directory to test3 site
e. removed setup.php from test3
f. set up admin password
g. noticed SAME ERROR - Table 'nippers3.comments' doesn't exist

url is
[url]www.test3.nippershair.co.uk
[/url]

help - have ensured using same MySQL database i.e v.5
error occurred on test2 as well when I restored to mysql v.4

site seems to work and database is readable

however... note am using code to display article on main page

CodeDownload  
openside("");
require_once INCLUDES."comments_include.php";
require_once INCLUDES."ratings_include.php";

$article_id = "2";

if (!isset($article_id) || !isNum($article_id)) fallback("index.php");
if (!isset($rowstart) || !isNum($rowstart)) $rowstart = 0;

$result = dbquery(
"SELECT ta.*,tac.*, tu.user_id,user_name FROM ".$db_prefix."articles ta
INNER JOIN ".$db_prefix."article_cats tac ON ta.article_cat=tac.article_cat_id
LEFT JOIN ".$db_prefix."users tu ON ta.article_name=tu.user_id
WHERE article_id='$article_id'"
);
$res = 0;
if (dbrows($result) != 0) {
$data = dbarray($result);
if (checkgroup($data['article_cat_access'])) {
$res = 1;
if ($rowstart == 0) $result = dbquery("UPDATE ".$db_prefix."articles SET article_reads=article_reads+1 WHERE article_id='$article_id'");
$article = stripslashes($data['article_article']);
$article = explode("<--PAGEBREAK-->", $article);
$pagecount = count($article);
$article_subject = stripslashes($data['article_subject']);
$article_info = array(
"article_id" => $data['article_id'],
"user_id" => $data['user_id'],
"user_name" => $data['user_name'],
"article_date" => $data['article_datestamp'],
"article_breaks" => $data['article_breaks'],
"article_comments" => dbcount("(comment_id)", "comments", "comment_type='A' AND comment_item_id='".$data['article_id']."'"),
"article_reads" => $data['article_reads'],
"article_allow_comments" => $data['article_allow_comments']
);
render_article($article_subject, $article[$rowstart], $article_info);
if (count($article) > 1) {
$rows = $pagecount;
echo "<div align='center' style='margin-top:5px;'>\n".makePageNav($rowstart,1,$rows,3,FUSION_SELF."?article_id=$article_id&")."\n</div>\n";
}
if ($data['article_allow_comments']) showcomments("A","articles","article_id",$article_id,FUSION_SELF."?article_id=$article_id");
if ($data['article_allow_ratings']) showratings("A",$article_id,FUSION_SELF."?article_id=$article_id");
}
}
if ($res == 0) redirect("articles.php");
closeside();





is that a problem?
dbcount("(comment_id)", "comments"
=>
dbcount("(comment_id)", DB_COMMENTS,
You are a star

Thank you so much
I was sure there was much more to change

Thank you very much

:)
Thread Information
Author
Replies
7 posts
Views
2,085 times
Last Post
Last updated on 11 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Matonor, neltek