Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

SMTP with Auth ?

I can put only host but most of SMTP servers using Auth now so how to setup this in PHP-Fusion ?
PHP-Fusion does not allow you to set all values required by most emailing systems, there is 9 parameters which is supported by PHPMailer which PHP-Fusion uses, PHP-Fusion fully supports only 4 and one not fully.
The only way to setup other parameters is to edit sendmail_include.php or phpmailer_include.php in includes folder.
If im not so skilled with that can You (someone) wrote here what should i do to send emails throw smtp.google.com ? STARTTLS (SSL), Port: 465 or 587 and Auth ???
I found that :
SMTP Host: ssl://smtp.gmail.com:465
SMTP Username: nick_gmail@gmail.com
SMTP Password: Yours password

For v.7 should be enough without makin any changes in sendmail_include.php or/and phpmailer_include.php

But for me it's shown that Send mail failed, caontact with Admin...
The thing is... current version of PHPMailer included with PHP-Fusion does not support connection prefix which is required to use gmail SMTP.
here is list of settings you need to set for gmail in latest PHPMailer version:
public $From='nick_gmail@gmail.com';
public $FromName='Nick Gmail';
public $Mailer='smtp';
public $Host='smtp.gmail.com';
public $Port=587;
public $SMTPSecure='tls';
public $SMTPAuth=1;
public $Username='nick_gmail@gmail.com';
public $Password='password';
Sorry, but steel not workin... Is there posibility to got that php files in zippack ? maybe mine are bugged or something, and if i done with that variables i must setup in misc ?
Which files i must modify ? there is:
phpmailer_include.php
smtp_include.php
class.phpmailer.php
class.smtp.php
Language string failed to load: tls
WTH ?
PHP version?
tls works fine only with latest PHP version which is 5.2.5 or newer.
Then its PHPMailer bug... post full error message and PHPMailer version you using...
also, did you tried to replace old PHPMailer files who came with PHP-Fusion with newer you downloaded?
i used this PHP-Mailer which is linked here, and PHP-Mailer which was in PHP-Fusion with... so
well you see... PHP-Fusion uses quite old version, so you can't just download new version and replace old files... PHP-Fusion simply not comfortable with new version.
i did mate ! I did! In old version is VAR not PUBLIC (variable)
Thanks for brining this up. We are currently working on the next version of PHP-Fusion (v7.01) and this is something we should put in. Port and auth should be added to the settings and we will upgrade our version of PHPMailer.
So hooah ! That will be little pice of sand from me to PHP-Fusion :D
@Starefossen: That's a spirit...
So we are waitih for 7.01 :D
So it's done in 7.02 version ? If yes, what should i do to use gmail for sending mails from php-fusion :) ?
Thread Information
Author
Replies
19 posts
Views
12,246 times
Last Post
Last updated on 9 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: starefossen, bite, krisop