Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

DB backup problem.

Hello there.

I have a site I'm going to renew from the bottom and up.
But before I do that I want to make sure I have a fully working backup of the old site.
I have taken a backup of the DB through PhPMYadmin : https://dbadmin.one.com/
And I have uploaded all the old files from the original site to my test site.
But when i try to upload the DB backup to PhPmyadmin it says that the file is to big (17mb is the size btw).
and the help file they refer to is not that help full.

So I am hoping that one of you guys can help me with this problem so that I can get on with the renovation of the domain :)

If you need any more info just say it and I'll deliver the best i can.
in the Import section enable Allow interrupt .... and keep on importing until it says it is finish with the whole file
Partial import
Allow interrupt of import in case script detects it is close to time limit. This might be good way to import large files, however it can break transactions.
Number of records(queries) to skip from start


can't remember if you need to write in the Numbers og records field, after the first import, but if you need to do that it will write the number og imports done when it stops
i224.photobucket.com/albums/dd18/NielsRy/Udklip-1.png

Ive set it up in this matter but it still comes with the error message :(
What have i set wrong?

If your speaking danish a reply in that language is also welcome ofc. :)

Quote

Caligo wrote:
i224.photobucket.com/albums/dd18/NielsRy/Udklip-1.png

Ive set it up in this matter but it still comes with the error message :(
What have i set wrong?

If your speaking danish a reply in that language is also welcome ofc. :)


argh forgot that one.com has a max of 8MB filesize

then you need to split your export, do not select all tabels at once, export the large tabels for them self, and all the small tabels together

yes i can Danish, i'm from Denmark, but on this site i will only answer in english
I understand :) ofc it should be in english on this fora.
I'll try and do what you sugested tomorrow :)
I hope it will work and thx.
I'm still getting one file which is to large (12mb)
and it is caused by the section called
fusion_guestbook
That specifik sektion is the one on 12mb
how do i tackle this problem then?
Well if there is no apparent solution to my problem is there a way to test the site and the database local on my machine? So test that all the original posts and such has been backed up?:)
export the fusion_guestbook to a sql file, open it in a editor and then cut and paste some of the INSERTs into a new file

or PM a link where i can download that file or mail me that sql (zip it first) then i split that file for you
Think i solved the problem with the size by myself.
I tried using the zip funktion when i downloadet it and that really helped with the size.

But when i import em to the other databse it gives the following error:
CodeDownload  
Fejl

SQL-forespørgsel:

-- phpMyAdmin SQL Dump
-- version 2.9.2-Debian-1.one.com1
-- http://www.phpmyadmin.net
--
-- Vært: MySQL Server
-- Genereringstid: 22/09 2009 kl. 18:21:24
-- Serverversion: 5.0.32
-- PHP-version: 5.2.0-8+etch15
--
-- Database: `foe_caligo_dk`
--
-- --------------------------------------------------------
--
-- Struktur-dump for tabellen `fusion_messages`
--
CREATE TABLE `fusion_messages` (
`message_id` smallint( 5 ) unsigned NOT NULL AUTO_INCREMENT ,
`message_to` smallint( 5 ) unsigned NOT NULL default '0',
`message_from` smallint( 5 ) unsigned NOT NULL default '0',
`message_subject` varchar( 100 ) NOT NULL default '',
`message_message` text NOT NULL ,
`message_smileys` char( 1 ) NOT NULL default '',
`message_read` tinyint( 1 ) unsigned NOT NULL default '0',
`message_datestamp` int( 10 ) unsigned NOT NULL default '0',
`message_folder` tinyint( 1 ) unsigned NOT NULL default '0',
PRIMARY KEY ( `message_id` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 AUTO_INCREMENT =2593;

MySQL returnerede: Dokumentation
#1050 - Table 'fusion_messages' already exists



what does this mean and how do i solve it?
that the table exists, delete all the tabels so you have a empty database and try again
Many thanks for the support! :D
It all helped and i have now tested the DB and it seams that it was a successful backup :)
Again thanks for the quick and useful support.

ps. Only little "problem" i have is that it replaces "ø" with "Ã," and æ with a nother couple of symbols.. and likewise with å.. but gues i have set something wrong somewhere. :)
it because your database use the wrong Kollation (Collation)

you need to start over and before you import change the Kollation (Collation) to latin1_swedish_ci or latin1_danish_ci

then you have the Danish charters
You can change the collation by hand in phpmyadmin.

For such large files I recommend a program like sqlyog
Well i dont know if I'm looking the right place.
Under operations i check what it's set to and it shows latin1_swedish_ci on both phpmyadmin sites. I have even tried changing it on my test site to the danish one.
When i upload the file i also remember to set it to latin1.
So could you tell mere where more precisely i should look? or where to set it:)
Again thanks for the quick support.

Ps. even tho it does not show the æ ø and å correctly the database backup is still complete right?.
it does not seem that any thing is missing on the test site just that the letters are missing and being replaced by other letters/symbols. So i can safely presume that i have a working db backup and that it is just a matter of settings on the import part?
do you have the Danish charters in your sql file or is it the other charters

if you have the Danish charters in that file i have no clue of what is wrong

is the "MySQL forbindelses-sammenkøring:" set to utf8_general_ci
The "MySQL forbindelses-sammenkøring:" is set to utf8_unicode_ci on my test server and on the original server its set to utf8_unicode_ci

So should that be different or?
And i could still mail you the dbbackup if theres any thing for you to find there?

I can also take screens of the different setups.
mail the sql file to me and i look at it, zip the file B)
Problem solved thanks to SiteMaster.
Thanks for the great support! :)
Absolutely top-class.
and the solution to it was that he forgot to select utf8 in the import section
Intimately, the post is actually the best on this laudable topic. I harmonize with your conclusions and will eagerly look forward to your future updates. Saying thanks will not just be adequate, for the fantastic lucidity in your writing.
Omaha Steaks
Omaha Steaks
Thread Information
Author
Replies
20 posts
Views
4,724 times
Last Post
Last updated on 10 years ago
Related Threads
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Wanabo, SiteMaster, Caligo, AlianBrin333