Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

upgrading from 7.00.07 to 7.01.01


Print Track
Is there any consideration I need to take before upgrading to 7.01.01?

How do I do it? - Just overwrite the files or?

Thanks.

24 replies

Quoted from the included readme-en.html file:

Quote

UPGRADE FROM V7.00.XX
Before you upgrade we strongly recommend that you backup your files and your database as PHP-Fusion 7.01 is a major update from PHP-Fusion 7.00. You need to follow these instructions precisely.
1. Version 7 code is mostly compatible with version 7.01, however since there are a lot of changes to the core some addons (mods, infusions, panels or themes) may not work properly

2. You must first upload the upgrade script from the folder named 'upgrade v7' to the administration folder of your site and upload the folder named 'locale' to the root of your site. Without the locale files, some names may not be added to the database.

3. Login to your site as the Super Administrator. Under the System Admin tab of the Admin Panel, click on Upgrade then click the button marked Upgrade. YOU MUST perform the upgrade first! The upgrade process will complete only when you see 'Database upgrade complete'.

4. VERY IMPORTANT: Since this release contains a number of structural changes, some elements of your site will not work properly until you have updated all of your files. YOU MUST upload ALL of the files from the files folder.

If at all you are any doubt please feel free to ask one of our support sites for help, there are plenty of knowledgeable users in our community who can help or advise you regarding the upgrade process.
yes, but I don't understand

Quote

2. You must first upload the upgrade script from the folder named 'upgrade v7' to the administration folder of your site and upload the folder named 'locale' to the root of your site. Without the locale files, some names may not be added to the database.


When I need to upload files from files folder? Thanks!
The file you first should upload to the server is (from the v7.01.01 download-package) :

/upgrade v7/upgrade.php

This file upgrade.php you upload to /administration/ on your FTP-server.

From there you just following the readme-file.
Okay, first I tried on my localhost. But there was many errors.

There were my steps of upgrading:
1. I have set theme to primary and language to English.
2. I have upload upgrade.php in /administration.
3. I upload folder /locale from v7.01.01 download-package to root of my site
4. I've upgrade
5. I've got many many errors.

What I done wrong? Thanks!! :)
After step 5 you need to upload all of the files from the map named "files".
thanks, now it works! :)

but i have a new problem -.-" when I upload translate with my language is problem in shoutbox, because there is error in shoutbox_panel.php on line 39, because in my locale is charset windows-1250.

how to fix this? thanks!! :)
No Problem.

I think your last questio/request belongs in a new thread - not in this one. ;)
I am on version V7 now do I really need to upgrade to v7.01.00 or just leave it as it is. My site is my life line and I am scared to lose it.:|
Well, if you just have backup of all files from the FTP-server - and a backup of your database too before you begin to upgrade - then you can't loose any data/files at all.
Does that save all my custom pages that are in there? I have about 400 custom pages in my site. Sorry new to upgrade..lol
Like I wrote:
Well, if you just have backup of all files from the FTP-server - and a backup of your database too before you begin to upgrade - then you can't loose any data/files at all.

So you won't loose anything if something should go wrong in the upgrade.

But be 112% sure that you have backup of both all the map/files from your FTP + a databasebackup too.
Hello, i've done all the step. I first uploaded some files, then all the files, but it doesn't work. Each time I click on "upgrade" i get this error message:

Quote

Warning: require_once(../themes/templates/admin_header.php) [function.require-once]: failed to open stream: No such file or directory in /mounted-storage/home23a/sub001/sc11219-RTUF/www.alix-henriol.com/menu/administration/upgrade.php on line 19

Fatal error: require_once() [function.require]: Failed opening required '../themes/templates/admin_header.php' (include_path='.:/usr/share/php5/') in /mounted-storage/home23a/sub001/sc11219-RTUF/www.alix-henriol.com/menu/administration/upgrade.php on line 19


I want to specify that i'm currently tying to upgrade from v6.01.11

smokeman, how much would you charge to upgrade my website? >.<
Just read the readme-eng.html carefully.

First upload the upgrade.php + locale-files. Then upgrade from the Admin Panel on your site. Last upload all the rest of the files from the download-package.

Again - it's all in the readme-file.
Oke readme-file where can i find that?
readme file in archive with CMS
I'm confused, I see upgrade packages to go from 7.00.00 up to 7.00.07, and upgrade packages to go from 7.01.o1 to 7.01.02, but no upgrade package to go from 7.00.07 to 7.01.00

If I have 7.00.07 what is the correct way to upgrade to the current version????
that is confusing.... i just upgraded from 7.00.07 to 7.01.00, just make sure to BACK UP everything first (including the php files & databases).

Quote

GMUDuckman wrote:
that is confusing.... i just upgraded from 7.00.07 to 7.01.00, just make sure to BACK UP everything first (including the php files & databases).


But WHERE did you get that upgrade package, There is NOT an upgrade package to go from 7.00.07 to 7.01.xx ANYWHERE in the downloads, the archived downloads, or anywhere else that I see... ?????
author brinck
forumUpgrading issues - 8
replies25 posts
viewed10,732 times
activeLast updated on 9 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Homdax, brinck, WEC, smokeman, Harly, Chaddy, imaqt430, Vogeltje40, jikaka, GMUDuckman, mnovi, alix