Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Installation Issue stuck at step 4

I hope someone may be able to help me with a new installation that I am having a problem with.

I have successfully installed a PHP-Fusion on a couple of servers, this is the first time I have had an issue.

I'm stuck on step 4 of the installation. I enter all database user credentials as requested in step 3 I click next and I get a screen headed "Step 4: Config / Database Setup" the rest of the page is blank I cannot proceed any further.

Does anyone know what might cause this to happen.

Regards
Oh k !!!

So it means that you are able to Continue with the Database Settings.

So Can you see same as this screenshot ?
img138.imageshack.us/img138/2070/screnfsn.png

But Please tell us more about the Step 4, i.e, Config Database Setup.
Is it just showing the Config Database Setup Text ?
Or it is also showing:

Quote

Database Connection Established
Config File Successfully Written.
Database tables created.

Or it is not showing the NEXT button ?

You should better provided the Screen shot !!!

Merged by PF:

Have you tried Opening your Website again ?
Is it opening the Setup again or it is installed and working...?

If you are not able to see next button or some text missing, then it may possible that page is not loaded properly...

Can't say more than this... :(

Polarfox:
Use the edit button, Luke!
And read: http://www.php-fusion.co.uk/coc.php#12x
Hi Ankurthakur

this is what is see for step 4

img257.imageshack.us/img257/753/phpfusion.png

I have re run the set-up and I get the same issue each time.

Regards
Upload setup.php again. XD
Hi Fangree

I have uploaded a new setup.php file but the same problem occurs.

Regards
hmmm thats a weird one. Let me think about this.

Have you renamed _config.php to config.php
Just double checked and the the config.php file is named correctly.
No idea sorry. Wait for the professionals.
No problem, Thanks for trying Fangree.
hmmm.

Whats your host?
SQL Version?
PHP-Version?
Oh I am sorry !!!

I will take care about the Rules ...

However, this is really weird that it is very unknown problem.:@

After Reading the whole setup.php and its locale, I couldn't say anything about the problem :(

Don't know whether this will work or not, but you can try Deleting the Fusion Database tables completely and then Re Installing it...B)

Please let us know if it works.... :|
He obviously has not got any Fusion SQl tables as he has not passed that process in setup.php lol

Read!!!
But I think that the Settings for database are done on the step 3 and he is on the step 4 !!! B)

But dammit, its not showing the result :@
Ok Guys,

My PHP version is 5.3.2-1ubuntu4.5
Mysql is Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (i486) using readline 6.1

I am running this on my own Ubuntu server

Regards
Ubuntu server that could be the problem then coz it all works fine on a normal live website. lol
My Brother is using Ubuntu on my Current System and I don't think that this could be a problem.

You may check by doing a Newly Fresh Installation by deleting databases and recreating the Database User by giving ALL PRIVILEGES to it.
Ok, I will remove the database and users a create again from scratch.

I really appreciate the help so far guys. I will update shortly.

Regards

Merged by Polarfox

So guys, i have removed and recreated the database and user. i have started with a fresh install of Php-fusion and im getting the same problem.

Any further help on this would be gratefully received

Regards

Polarfox:
Same story, read the http://www.php-fusion.co.uk/coc.php#12x please.
Ubuntu server that could be the problem then coz it all works fine on a normal live website. lol
I have managed to resolve this issue.

It was caused by my php.ini file. once i uncommented (removed semicolon) the line "extension=mysql.so" and restarted apache everything came to life.

Hope this helps someone in the future

Thanks again to everyone that tried to help on this.

Regards
Apache without mysql? Weird things, maybe another db used.
Thread Information
Author
Replies
21 posts
Views
4,395 times
Last Post
Last updated on 9 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Craig, PolarFox, Ankur, 42Xan, mohdmewati