Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Ecstatic Theme - v7.01.XX - Release


Print Track

18 replies

Why don't you offer it here to download?
Well W3C standards are pretty much a joke. To get a theme officially here to download you'll need to have the template comply with the standards.

Last I checked the site has errors according to there "standards". That results in the theme being rejected. Even though it works perfectly well with all the major browsers.

Quick note before I'm flamed about W3C. Learn the facts.

The top 5 websites don't even comply with there standards, this includes Google, Yahoo, Microsoft, etc.

1- Marquee is not validated
2- Image mapping not validated
3- Flash need some extra work to validate and after you finish you’ll discover that it’s not compatible on all browsers
4- Most of famous WYSIWYG editors generate code that fail to validate
5- You have to replace all ‘&’ in your HTML with ‘&’ and all your attribute values have to be closed within “” tags without a good reason

So it fails on my list.. lol

To be fair it’s not a bad validation tool, it’s a good free tool to help you fixing some of the browser compatibility problems and find broken links and find images without alt tags
If you notice any problems with the theme, please report here so I can fix them.

The only problem I've noticed is with the news, the cat image puts the text out of place.

This is however a problem within PHP-Fusion and not the theme itself.
nice theme!
Great work again NetriX.
Hmm...! Modern Theme :) Good Work Netrix and Thanks......... ;)

Quote

3- Flash need some extra work to validate and after you finish you’ll discover that it’s not compatible on all browsers

Bull****. Check flash bbcode in PHP-Fusion - it use Flash Satay method. But in another points, you're right.

Quote

jantom wrote:

Quote

3- Flash need some extra work to validate and after you finish you’ll discover that it’s not compatible on all browsers

Bull****. Check flash bbcode in PHP-Fusion - it use Flash Satay method. But in another points, you're right.


You have to go out of your way to validate flash code. For example, if you copy and paste the embed code exactly from YouTube then your automatically violating the W3C guidelines.

There is no Flash standard that is maintained by the W3C or IEEE. It is wholly owned and managed by one company. This gives a great amount of potential power to Adobe over the direction of the web. The last time this issue came up it nearly destroyed the foundations of the web.

I can't wait til' HTML 5 comes out and destroys it! :P

Quote

NetriX wrote:
Well W3C standards are pretty much a joke. To get a theme officially here to download you'll need to have the template comply with the standards.

Last I checked the site has errors according to there "standards". That results in the theme being rejected. Even though it works perfectly well with all the major browsers.


No need to be so defensive about it. For starters we have relaxed the rules a bit regarding WC3 validation. The Addon approvers have been allowed to use their own judgement when deciding on a submission as getting a theme fully valid for all browsers can sometimes be nigh on impossible or it could mean having to reduce some functionality in order to comply.

Though, I don't see why anyone would have a problem with us insisting on higher standards. Yes, it can be a pain in the ass completely validating a theme. But, because of the myriad of configurations a site may have to comply with, it's essential that any any Addons we provide to the public be as safe and as functional as humanly possible.

I agree that some sections of this site are not valid, which is something we're working on. However, they are minor errors unlikely to cause problems in any browsers.

p.s. I was unable to have a look at your theme as your site is in maintenance.
@Philip. You can see a live demo at http://demo.phpfusionmods.com/.

As for the main site, I've deleted everything and starting over. Got a big surprise for the community coming up. ;)
Remember guys, we're here to help - not hinder.
If you have a theme with a few validation faults, ask for help. We have some excellent theme coders on staff who would be very willing to give you any assistance.

[url=http://www.php-fusion.co.uk/profile.php?group_id=27]
You can also contact any of the Addon Approvers for advice before submitting your work.[/url]
@Philip : Roger That !!! :)
Love the theme, its very techie. The color combination is also perfect, so futuristic.
Well, the theme has to many errors, it's not even rendered properly in Firefox.
Install HTML Validator(in Firefox) and be amazed of how many mistakes you did.
To mention a few:
- missing <tr>
- <img... tags not closed,
- opened <div>s and not closed
- closed <div>s without being opened
- missing </table>
- missing </center>
and the list continues... no surprise that the theme is not valid.
Netrix, again, please post stuff where it belongs. Theme releases do not belong in General Discussions.

Quote

JoiNNN wrote:
Well, the theme has to many errors, it's not even rendered properly in Firefox.
Install HTML Validator(in Firefox) and be amazed of how many mistakes you did.


Well, I think Netrix has posted something about it in his Post#3. There may be some problems related to the W3C standards/Validations.

But, if you see any problems in the Theme Design, then you should report it to him... B)
Info: I've corrected this theme so it meets the W3C-standard - EXCEPT two small errors regarding the CSS. But the XHTML is 100% valid now. (have removed the stupid MARQUEE). The open/close function for the side-panels now working too. But lol NetriX - no harm against you - but you have a very funny way to code. From top to bottom the hole code you are going in and out of the PHP-tags. That's not neccasary at all - it just gives some "bad" code IMO. Why not use 100% PHP instead ? I've corrected that too.

The theme will look the same now when looking with IE/FF.

Demo: www.dev.dvdside.dk

Download: www.dev.dvdside.dk/downloads/ecstatic...pdated.zip

NetriX: Pls say when you have the updated version so I can delete it from my server again. I can't attach the theme here because the filesize is too big.
author NetriX
forumThemes Support
replies19 posts
viewed8,319 times
activeLast updated on 8 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Homdax, Craig, smokeman, jantom, HobbyMan, NetriX, jikaka, Rolf Mayer, Ankur, JoiNNN, Teresad1