Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Problem with cyrillic translation

Hi. I'm from Bulgaria and I'm translating english locale into bulgarian. But I have this problem. When I install php-fusion .. he was in english and my admin panel was in english. Now when I translate the admin panel ... the links are still in english. I try to edit them by phpmyadmin, but when I translate some of the admin panel link by phpmyadmin ... the link became something like ????? ... and now I must install new php-fusion with bulgarian locale ... cause I don't see another wayt .. to have bulgarian admin panel.

Does anybody know haw to fix this ... so I would not have to install php-fusion again?

p.s. I'm talkig about main site link in admin panel.

Thanks.
PHP-Fusion is not he or she :P

Try opening your locale/Your_Locale/global.php and do setting for :

$locale['charset'] = "iso-8859-1";
$locale['xml_lang'] = "en";

Set the setting as :

$locale['charset'] = "UTF-8";
$locale['xml_lang'] = "bg-BG";

and see what happens !
// Locale Settings
setlocale(LC_TIME, "bg","BG"); // Linux Server (Windows may differ)
$locale['charset'] = "cp1251";

This are my settings in global.php

When I put UTF-8 ... all site becomes in rhombus whit ? inside :(
Ensure that, your Locale files should also be in the Encoding of UTF-8 in which the locales are saved.

I've used UTF-8 characters for my website which were not working before I converted all my Locale files to UTf-8 Encoded !

Have you done both the settings ?

$locale['charset'] = "UTF-8";
$locale['xml_lang'] = "bg-BG";

?
Done. I've change encoding of all my locale files to UTF-8. Now ... how to translate admin panel main links from english to bulgarian.

Thanks.
You can edit the locales for admin panel in locale/Your_Locale/admin/ all files here !

The File for the Main Links is locale/Your_Locale/admin/main.php
I've translating those files already, but I've installed my php-fusion in english locale (the setup was in english) and now .. the admin panel links still stay in english although thath i've translate the main.php in bulgarian.
Hi,
try this:
in Admin panel -> Main settings: switch from Bulgarian to English, and then back to Bulgarian again.
It's work! Thanks very much :)
I'm pleased to hear this old trick still work m8 :)
I have another question. Why I have to use UTF-8 encoding for cyrillic? I saw that english locales are in ANSI? Now ... when I turn on english locale all my menus and text that are on cyrillic become rhomboids with a question mark in them.

Am I suppose to using UTF-8 for encoding?

Thanks.
Thread Information
Author
Posted In
Replies
11 posts
Views
4,849 times
Last Post
Last updated on 10 years ago
Related Threads
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Sveinungs, rUMENcho, Ankur