Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Facebook Connect Panel

www.php-fusion.co.uk/infusions/marketplace/uploads/image/t_1123.pngThis Infusion will allow you to Add a Connect button in your Website using which Visitors can Register on your Website using their Facebook Accounts.

People will just Use their Facebook Account to Log-In to Website.

It provides a 1-Click Log-In using Facebook.

Features :

- 1 Click Log-In using Facebook Account
- Profile Image Imported Automatically via Facebook
- No Core Editing and Easy to Use and maintain


INSTALLATION :

Either See the Readme inside it, or Follow instructions given at : http://ankurthakur.in/forum/viewthrea...8#post_336



-- View this Addon --

Cool infusion very easy to set up.
Continue your good work.
I'll try it out later this day, hopefully is doesn't give me that f*** loop-problem I had with the one Netrix made.

Quote

assensvejdk wrote:

Cool infusion very easy to set up.
Continue your good work.


Thank you :)

Quote

dusk wrote:

I'll try it out later this day, hopefully is doesn't give me that f*** loop-problem I had with the one Netrix made.


I found that problem with this one too while Testing but I made a fix for that :X
Good Work Ankur, thanks for infusion :)
Seems that Facebook-connect thingies hate me :s .

Config filled in like it should, facebook-app seems ok but then... : I'm asked for mermission by the app, are getting back to the site but while the facebook_connect_panel states that I'm logged in, I'm not loggin in in the site.

errors in log :

CodeDownload  
facebook_connect_panel/facebook_connect_panel.php
 Undefined index: fbc_userid Line: 60

facebook_connect_panel/facebook_connect_panel.php
 Undefined index: fbc_userid Line: 64

facebook_connect_panel/facebook_connect_panel.php
 Undefined index: fbc_userid Line: 41

facebook_connect_panel/register.php
 Undefined index: fbc_userid Line: 35

Someone any idea what could be wrong here?

Quote

dusk wrote:
I'm asked for mermission by the app, are getting back to the site but while the facebook_connect_panel states that I'm logged in, I'm not loggin in in the site.


1. If you are a guest, you will be prompted to Sign In to facebook.
After that, you will be taken to register.php page where you will sing up by entering some password.
After that, you will be logged in.

2. Or if you are already registered, then Log In and then connect to facebook. Then it will join your Member account with facebook account so that you can use any of them to log in.

What problem are you having ? Can you please explain it more ?

I will resolve those errors in next version !
When I am register and login on the site and when i want connect the profile with Facebook, it send me to the file infusions/facebook_connect_panel/register.php, Infusion show me Facebook Name, E-Mail Address, Profile Picture, but on the top of panel is written: Failed to Update your Information!, when I click to another reference (ex. Home Site, Contact..) i am redirect to this same file...
If I`am not register (and of course not login) it works fine.

My site: http://bkssparta.pl/news.php

Ps. do you understand me? :P
Well, on connection with facebook it returns to the site. The panel states that I'm logged in but I'm actually not.

I'm also not redirected to the register.php page, it just goes to news.php.

When I log into my site the normal way , every sitelink I click gives me a center panel : Connect to facebook but it's empty...
In the error log I'm getting the errors I posted before...
I added some screenshots to make it somewhat clear :

www.mcnw.be/pc1.png

www.mcnw.be/pc2.png

www.mcnw.be/pc3.png

Quote

Piotrroger wrote:

When I am register and login on the site and when i want connect the profile with Facebook, it send me to the file infusions/facebook_connect_panel/register.php, Infusion show me Facebook Name, E-Mail Address, Profile Picture, but on the top of panel is written: Failed to Update your Information!, when I click to another reference (ex. Home Site, Contact..) i am redirect to this same file...
If I`am not register (and of course not login) it works fine.

My site: http://bkssparta.pl/news.php

Ps. do you understand me? :P


Did you installed it through Admin Panel --> Infusions --> Facebook Connect Panel ?

Quote

Well, on connection with facebook it returns to the site. The panel states that I'm logged in but I'm actually not.


Weird... The Debugger Panel shows that everything working OK, except the Facebook is not returning any values into your application. Otherwise, the photo must be shown in place of that Question mark. It works normally too.

Seems to be problem with your application. Try checking the config.php again and settings in your Facebook App. This is all I can say.
Of course I do it (and re-install all Infusions too) :)

img21.imageshack.us/img21/3650/facebookmq.jpg
I followed the steps for creation of the app you provided in the zip file. Are there any settings I have to look at especialy in the app? The config file is filled in like it should (believe me I checked the id and secret key a few dozen times).

Thank you for your quick replies and the help.
What more, (I don`t know is that must be) in adress I have 3 chars: _=_ (adress/facebook_connect_panel/register.php#_=_).

Hyh, on your site I have this same :D
Meybe it`s some problem with Polish users?
Can you guyz please provide your website Links ?

It works OK on my website and some other websites like assensvej.dk, sjove-joke.dk...

Quote

Piotrroger wrote:

What more, (I don`t know is that must be) in adress I have 3 chars: _=_ (adress/facebook_connect_panel/register.php#_=_).

Hyh, on your site I have this same :D
Meybe it`s some problem with Polish users?


On my website, it shows that you didn't registered with Facebook account. So you found any problem there ? Try connecting your FB Account by Loggin in and then connectin on my site and tell me if it works...

That is not the problem. Those characters should be there.

You said, that you are registered. And you tried to connect after you Logged into your site, that is Connect Member account to Facebook account.
Then, It fails if :
1. Website fails to update database (possibly not the problem according to me)
2. If there is another User in Database with the user_fbauthid as your Facebook User ID. You can get your Facebook profile ID at : http://graph.facebook.com/your_Profile_name/
And check if any User is there with that ID. You can check your Facebook Registered members in Admin Panel --> Infusions --> Facebook Connect Panel

Quote

dusk wrote:

I followed the steps for creation of the app you provided in the zip file. Are there any settings I have to look at especialy in the app? The config file is filled in like it should (believe me I checked the id and secret key a few dozen times).

Thank you for your quick replies and the help.


I guess that there is some problem with your Domain as Facebook is not giving you profile info. So better test it with some other Domain.

There isn't any other setting in Facebook App I think. See below :

i41.tinypic.com/4g69g3.png
Install this almost great MOD.
But it looks like it works, but when i click the connect button, this error is coming.


Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/includes/config.php:1) in /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/includes/facebook.php on line 37

[syntaxhighlighter brush=php,first-line=1,highlight=0,collapse=false,html-script=false]Warning: Cannot modify header information - headers already sent by (output started at /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/includes/config.php:1) in /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/redirect.php on line 106[/syntaxhighlighter]

what can i do to fix this error?
I`ve record that problem.
You can download file with film there:
http://www.megaupload.com/?d=GVEVNFIA
or see online there:
http://www.megavideo.com/?d=GVEVNFIA

My website: http://bkssparta.pl/news.php
Whoops, wrong post. Sorry
@Piotrroger: Thanks a lot for that www.php-fusion.co.uk/images/smiley/grin.gif I just found a minor mistake in my code. I guess I forgot to change that.

Anyways, the change is required in facebook_connect_panel/register.php at Line 71 :
[syntaxhighlighter brush=php,first-line=1,highlight=0,collapse=false,html-script=false]if (dbcount("(user_id)", DB_USERS, "user_fbauthid='".$_SESSION['fbc_userid']."'"wink == 1)[/syntaxhighlighter]
Change to :
[syntaxhighlighter brush=php,first-line=1,highlight=0,collapse=false,html-script=false]if (dbcount("(user_id)", DB_USERS, "user_fbauthid='".$_SESSION['fbc_userid']."'"wink == 0)[/syntaxhighlighter]

Can you please test it on my site by connecting your account now ? smile

@Lifeguard: Try Uploading the files again from the given Link !

[ Download The Latest Facebook Connect Panel Updated with Fix ]
Yeah, now works! Thank you! :]
Thread Information
Author
Replies
85 posts
Views
49,985 times
Last Post
Last updated on 7 years ago
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.