Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Facebook Connect Panel

I still get the same eroor.
Checked all my keys from Facebook, en files.

:|

Hmz...

now i see this,

Er is een fout opgetreden in Ankur Thakur E-Stand. Probeer het later opnieuw.

In english it says,
there was an error with Ankur Thakur E stand. Try again later :)
So i am gonna put my apis in there, to see if it helps.

Edit
It looks like it works.
But when i give my permission to use the app, the redirect url is http://www.compu-web.nlindex.php/#_=_
this is not good.
where can i change this?

thanks for your support.

edit

Yes.
Now it works fantastic. Log in en out, works perfet.
thank you for this wonderful mod.
hmf... one strange bug.
when i click connect, it is ok.
but system said, not login. after a refresh i am logged in.
the redirect url after the first click on login ends on news.php#_=_

is this correct? please try it on www.compu-web.nl if you want.

sorry for my bad english

Quote


Quote

dusk wrote:

I followed the steps for creation of the app you provided in the zip file. Are there any settings I have to look at especialy in the app? The config file is filled in like it should (believe me I checked the id and secret key a few dozen times).

Thank you for your quick replies and the help.


I guess that there is some problem with your Domain as Facebook is not giving you profile info. So better test it with some other Domain.

There isn't any other setting in Facebook App I think. See below :

i41.tinypic.com/4g69g3.png


And what problem could there be with my domain then? Site is http://www.mcnw.be btw, I added it to my profile. Could it be because the dns of my site isn't reverse dns'd yet and returns the domain of the hosting company where my dedicated server is hosted instead of the domain i use? (I'm only guessing here...) I allready tried it on another domain (same server though and same ip, not reverse dns'd) and the problem is the same.

BTW Hapy Newyear for all those dedicated to the Fusion-cause :)
The problem is with your domain... It is not able to get the ID from facebook.

Yeah it could also be due to DNS issue. Are you sure that you did correct settings in Facebook App ? Because it gives https://graph.facebook.com//picture?type=normal as my Image which should not.

or try resetting the App Key from Facebook App page and using new key in your infusion.
Resetted the key, no difference.
I'm sure averything is correct in the app ( I just followed the steps you providede and didn't do anything else.. - about 15 times or so... :p ). Does any of the files in your zipfile need some special rights?
I think that there is some problem with your domain. Facebook may have blocked it or etc... No other changes are required in any file.
Just config.php and installation from admin panel page. !! weird !!!

Quote

Ankur wrote:

I think that there is some problem with your domain. Facebook may have blocked it or etc... No other changes are required in any file.
Just config.php and installation from admin panel page. !! weird !!!


I'm getting grey hair of this :) .
I'll get the reverse dns right next week, but if that doesn't help I don't know anymore.
Weird thing is that this panel : http://www.php-fusion.co.uk/infusions/addondb/view.php?addon_id=342 does work on my site, using an app id... strange...
this is a great infusion :D

one thing the PF logout dosen't work if you have loged in with FB, is that normal ?

Quote

SiteMaster wrote:

this is a great infusion :D

one thing the PF logout dosen't work if you have loged in with FB, is that normal ?


On my site it works.
Hello i have error for this addon:
when i click login i'm rediret to: site.com/index.php#base_domain=www.site.com

with no picture and no registration... what is the problem? (index.php is my home page)
I'm getting this error when clicking on the FB login icon on my site:

Quote

Warning: Unterminated comment starting line 2 in /home/content/a/t/s/atskeeve62/html/infusions/facebook_connect_panel/includes/config.php on line 2

Fatal error: fatal flex scanner internal error--end of buffer missed in /home/content/a/t/s/atskeeve62/html/infusions/facebook_connect_panel/includes/config.php on line 2


What? Line 2 looks like every other Line 2 of every php file I have....?


EDIT: Fixed

Quote

lifeguard wrote:

Install this almost great MOD.
But it looks like it works, but when i click the connect button, this error is coming.


Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/includes/config.php:1) in /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/includes/facebook.php on line 37

[syntaxhighlighter brush=php,first-line=1,highlight=0,collapse=false,html-script=false]Warning: Cannot modify header information - headers already sent by (output started at /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/includes/config.php:1) in /home/joeyahc4/domains/compu-web.nl/public_html/infusions/facebook_connect_panel/redirect.php on line 106[/syntaxhighlighter]

what can i do to fix this error?


Anyone know the fix for this? The link to Ankur's update isn't working anymore. I have this same issue.
If is the file saved in UTF8 charset, it's possible, that there are BOM in the file.
Well, his files are not formatted like most files. All the lines run together, if that's what you mean.

He had a fix for this problem, but his website is not longer online.

Does anyone have it?
I downloaded this infusion and looked, if config.php file is saved in UTF-8 and I found out, that the file is saved in UFT8. So, i don't know, which PHP editor are you using, but try to look for "BOM" settings. http://en.wikipedia.org/wiki/Byte_ord...order_mark (Wiki strikes against SOPA and PIPA, so you have to switch off javascript for example).
Hmm... some of the other users are also having the same issue but I am surprised that I could not find the reason behind it...

As miskith, may be this could be related to BOM (I didn't faced this problem so unluckily I dont have any idea about this)

Lets see if miskith have some good news for you... B)

Yes, my website is down due to some Hosting problems... may be my host is striking against SOPA ;)

Quote

miskith wrote:

I downloaded this infusion and looked, if config.php file is saved in UTF-8 and I found out, that the file is saved in UFT8. So, i don't know, which PHP editor are you using, but try to look for "BOM" settings. http://en.wikipedia.org/wiki/Byte_ord...order_mark (Wiki strikes against SOPA and PIPA, so you have to switch off javascript for example).


I just use Notepad to edit. I don't make code so never bother getting any type of php editor.

So you're saying all I need to do is reformat the php files and they may work?

EDIT: Ok, I'm using a program that allows me to use UTF8 and the files look normal. This is where I'm stuck at the moment, when I click 'Connect':

Quote

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/a/t/s/atskeeve62/html/infusions/facebook_connect_panel/includes/config.php:1) in /home/content/a/t/s/atskeeve62/html/infusions/facebook_connect_panel/includes/facebook.php on line 37

Warning: Cannot modify header information - headers already sent by (output started at /home/content/a/t/s/atskeeve62/html/infusions/facebook_connect_panel/includes/config.php:1) in /home/content/a/t/s/atskeeve62/html/infusions/facebook_connect_panel/redirect.php on line 106
BOM is only in UTF8 charset and in this file aren't any translation... So you can try to save it (/infusions/facebook_connect_panel/includes/config.php) in another charset like Windows1250 or ISO 8859-2.

EDITED: Or you can send me this file through PM (compressed into .rar, .zip or...).
Thread Information
Author
Replies
85 posts
Views
50,104 times
Last Post
Last updated on 7 years ago
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.