Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

PHP-Fusion 7.02 and PHP 5.4

Hi all,

I just got an email from the company behind my server about they will upgrade from PHP 5.3 to PHP 5.4:

Quote

As a part of the deveopment, it is time to upgrade our PHP installations from version 5.3 to 5.4. The new PHP version contains some new features, but also deprecates some old ones. The full list of features that are no longer available can be found at: http://www.php.net/manual/en/migration54.incompatible.php

You need to pay attention to the following:
If your website has been installed using our 1-Click-Installer (fx Wordpress, Magento or Prestashop), and your website is fully up-to-date, then you do not need to do anything. Then your website will be compatible with PHP 5.4.

If you have developed your website yourself or had someone do it for you, you need to ensure that it is compatible with PHP 5.4. Your developer can help you with this. This also applies if you have installed any third party plugins on your website. Ask the developer and ensure that it is compatible with PHP 5.4.

Why upgrade?
Just like Windows, PHP releases updates once in a while. It can be new features or just security patches. We are updating PHP when security patches are released, but now the time has come to replace PHP 5.3 with 5.4. Beyond a number of security patches and new features, PHP 5.4 is also a lot faster than its predecessor.

When will the upgrade take place?
The upgrade will be done on one server at the time. We will start with web1. When all web-servers are updated, we will move along to the pro-servers, The work will begin on thursday the 8th of august at 09:00 am CET. We do not expect any down-time during the upgrade.
lick-Installer (fx Wordpress, Magento or Prestashop), and your website is fully up-to-date, then you do not need to do anything. Then your website will be compatible with PHP 5.4.

If you have developed your website yourself or had someone do it for you, you need to ensure that it is compatible with PHP 5.4. Your developer can help you with this. This also applies if you have installed any third party plugins on your website. Ask the developer and ensure that it is compatible with PHP 5.4.

Therefore my question is, are PHP-Fusion 7.02 ready for PHP 5.4?
I has been looking for an answer in the forum, but not found it.
Ok Domi, so it sounds like I not have to think so much about it.
Thanks :-)
I am running quite a few sites on 5.4 with no issues.
We do have some deprecated things we need to adress in a PHP 5.5 version.
I hope we will be able to adress them even with the first V8 release.
Thread Information
Author
Replies
3 posts
Views
3027 times
Last Post
Last updated on 7 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, KFJ