Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Upgrading from 7.01.xx to 7.02.xx

Falk - Latest reply on 18-08-2018 21:34 by Grimloch

0

Falk
Falk
Make a full copy of your site.
Copy all your files and the database so you can restore it if something goes wrong.

Find and download a new copy of your locale , for minimum PHP-Fusion 7.02.05 in the downloads section

Extract these files and replace all your current locales in your /locale folder

Then download latest PHP-Fusion 7 version

Extract your files

Find the upgrade file in v701/upgrade.php

Copy the file upgrade.php to your administration folder and replace current file.

Go to your administration > system admin select the upgrade icon, it should say that a new major upgrade is available.

Push the upgrade button and wait for your new config. When the config shows save the content that are shown in a text file on your desktop.

At this point your site will not work.
You need to copy all the files from your downloaded pack and replace the old files.

Once this is done, open your config and replace the content with the new generated content you have. Delete setup.php.
Edited by Falk on 22-07-2014 01:07, 4 years ago
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)

Sort replies by

0

EmilyThomas
EmilyThomas
Is this still applicable or there have been some more recent changes and I should refer to them?

0

Falk
Falk
The above should work

0

Ardea
Ardea
Dear Domi,

I hope you still check this topic. :)
I wanted to use your Cookie Consent Panel, but I had the same issue like others: blank page after clicking on I consent cookies.
Therefore I wanted to upgrade my site version (it's v7.01.xx), but that became a huge mess!

I found this description of yours, but I didn't understand it completely.
1.) I have to download both the upgrade and the complete core PHP Fusion.
2.) I have to upload and overwrite the content of the /locale folder.
3.) From the unzipped PHP F. core I need to upload & replace the upgrade file from above mentioned folder. (I checked and saw that it's completely different from the one in the upgrade file, and it makes dbases, it they're don't exist - that's good.)
4.) I have to login on my site and make the upgrade. And background copy of the files the txt file shows.
5.) I have to copy the files from the downloaded pack. FROM WHICH pack: the upgrade or the core?!
Because in the upgrade pach there isn't any setup.php. If I need to copy all the files from the core package, then why do I need the upgrade package in the first place?

Please explain me. I'm not professional, just trying to run a site for a Hungarian translating team. :)

(Besides I've made a Hungarian translation for your Cookie Content Panel, and going to upload it now.)

Thank you for your help in advance.

Krisztina

0

Falk
Falk

Quote

Find the upgrade file in v701/upgrade.php
Copy the file upgrade.php to your administration folder and replace current file.


It is from the downloaded pack.

0

Ardea
Ardea
Erm... maybe I'm stupid, but according to your description, I have to download 2 packs... :)

The upgrade.php part I understood, but...

Quote

At this point your site will not work.
You need to copy all the files from your downloaded pack and replace the old files.

Once this is done, open your config and replace the content with the new generated content you have. Delete setup.php.


In the downloaded upgrade package there is no setup.php. So: do I have to copy all the files from the downloaded "Latest PHP Fusion 7 version" package?

Sorry for my slow mind. :)

Thanks for the fast help!

0

Falk
Falk
No, read the description of the procedure more carefully here : https://www.php-fusion.co.uk/infusions/wiki/documentation.php?page=204
You download the main pack & needed locale pack. Copy the upgrade.php and run that and not setup.
If you just follow it step by step it should work.

0

Ardea
Ardea
Ooooo, what the heck! :)
Today morning I read this once more, and finally realised that I mixed the local language pack with an upgrade pack... Pfff.

Thank you for your patienct, I'll try your method soon! :)

0

Falk
Falk
:G

0

Ardea
Ardea
Sorry for writing this here, please take this post to another place, if you like, but it's simplier for me...

I uploaded the hungarian language files for the cookiebar_panel, but only the two needed file. There is no need for other files to mess with, but I don't know, how to make localization other way... Could you please put in your package in the right mode? :)

The hungarian.php's coding I had to change to ANSI, otherwise the letters would be unreadable. But this way it'll be all right. I can send you a screenshot after upgrading my page.

Thank you. :)

0

Falk
Falk
No worries,
If you click on the down arrow in an Addon you will get options.
In this case, here is the full link for a translation submission : https://www.php-fusion.co.uk/infusions/addondb/submit_translation.php?addon_id=571
You will see a description and a clear image on what is expected for a translation.

0

Ardea
Ardea
I've seen it when used the down arrow :). Nevertheless I uploaded a zip only containing the two hungarian files (readme_hu and hungairan.php), I hope the admins won't reject that because of its 'renegade' content, and you'll be able to use it.
On my site so far I simply overwrote the existing english.php which contained the Hungarian translation. I hope you're not angry with me for that. :)

0

Falk
Falk
It will do just fine! :G

0

Ardea
Ardea
Well, I came back with some feedback...

Thank you very much for your help, the upgrade finally succeeded! :)

BUT the cookiebar_panel still doesn't work properly. Please tell me, how I could communicate with you, because I think we have to change some e-mails or such. There is a little problem with the text file (yes, with that one I uploaded), because after the upgrade it looks completely different and not so good... (I've made screenshots of them.) And although the text disappears after I click on button, but comes back right away, when I click on the same site, or other... :|

0

Falk
Falk
Cookie panel can coolide with some addon or theme that uses jQuery.
I don´t support by mail , these forums are for support so everyone who have similar issues can take part of the solutions if we find it.

0

Ardea
Ardea
Sorry for "disappearing", but I had a lot other things to do...

So. I don't know if my site uses jQuery, but I don't think so. It's very simply. :-)
And no addon is used, as far as I know.
Anyway, the message still doesn't disappear after clicking on the button...

Please check this site: http://www.hunositokteam.hu

I managed to solve the pop-up table problem (the size wasn't good, but I changed that in the proper file).
As for the cookiebar_panel's text file... now, that is a problem I couldn't solve.
I had to change back the text file to the original UTF8 coding, because the ANSI was not good after the version upgrade.
As you can see on the site, the text file is completely without accents. In Hungary we use ő í ű etc... In the pop-up table they all shown perfect, but in the consent part (on main site) they are screwed. The problem is that, they are in one text file, so I cannot use another char coding for that part.

What do you think? Is it worth changing the text file in order other it can be used properly in other langueges (like ours)?

0

Falk
Falk
You are using jQuery for sure, the overlay depends on it, it is native in Fusion.
The panel are indeed persistant, It seems that the cookie is not set, do you see any error messages in the errorlog?
UTF-8 is the one needed for 9

0

Ardea
Ardea
Eeer... Where can I find the error log? :)
Or it should be shown somewhere on the admin site? Because there aren't any errors appearing...
(I told you I'm a bloody amateur. :) )

0

Falk
Falk
You can find it under , Administration > System Admin > Error Log

0

Ardea
Ardea
Thanks.
I don't see any error in connection with this panel, but please take a look at it. I attached it here.
You do not have access to view attachments
Actions
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
More topics like this
Participated Users

Moderators:
{%user_avatar%}

Upgrading from 7.01.xx to 7.02.xx
by {%user_profile_link%} {%post_date%}