Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
I cannot see a way to search the support forum to see if this issue has already been raised so apologies if this is a repeat.

When I Select a category for product management the edit page is displayed with a list of products at the bottom.
Although I don't have many products they do require two pages.
At the bottom of the list on the first page the Order / # column only displays an up arrow so I am unable to push the item further down the product list order. Similarly on the second page, the Order / # column only displays a down arrow so I am unable to push the item further up the product list order. In effect the products cannot be moved from one page to the next.

The double arrow seen elsewhere should also be displayed on the last/first line where the is a page break in the listing.
Falk has replied to this - 1 year ago
Hi, please try with another theme and see if the same issue is there.
MRKegtsc has replied to this - 1 year ago
Sorry for delayed reply, other stuff got in the way.
I've checked 2point0, Aer, Atlantis, Fumaeleon, Gillette, Modern10, Pastel, Phos, Stylo,and galopcu. They all do it.
Falk has replied to this - 1 year ago
I do have a hard time to wrap my head around the issue you describe. However, Just push a top item and the other will move regardless.It is not a fix but a work-around.
MRKegtsc has replied to this - 1 year ago
I can send you a screenshot. I couldn't figure out how to include it in the post.
At the top of page 2, I can only push it down as there is no up arrow.
Falk has replied to this - 1 year ago
I get it now, definatly a wierd bug, but you can edit each item and set a manual order ( 4 / 11 etc ) if my memory serves me right. I do not have a system with it installed atm.
MRKegtsc has replied to this - 1 year ago
Your memory serves you correctly. I've now got around it by manually setting the sort order number.
It's a great little shop. Are you working on a F9 version?
MRKegtsc has replied to this - 1 year ago
Actually, a quicker way was to go in PHPadmin and query the DB as follows:
CodeDownload  
SELECT `id`, `title`, `description`, `iorder` FROM `phpf_eshop` ORDER by `iorder`


then edit the iorder value and refresh the query until the products were in the right order.
MRKegtsc has replied to this - 1 year ago
This must have come up before but I haven't spotted it.

I need to temporarily "remove" some products from my shop. I do not wish to delete them as they apply to an annual competition and will be needed again next year.

When I set a product's active state to "disabled" it is still listed in the shop for customers. Am I doing something wrong or is there another way to stop products being shown to customers?
Falk has replied to this - 1 year ago
That should indeed do the trick, is there any group options?, Access levels. Can set admin to some items or groups.
MRKegtsc has replied to this - 1 year ago
Nearly fixed it by setting:
Active = Disabled
Access = Administrator

Products are not listed in the shop but when the search function is used it lists the `hidden` products and when you click on them the page shows an error "Unfortunaly we could not retrive your requested data".
This is a bit confusing to customers.

So I've resorted to mySQL as follows to create a table with the removed products in so I can reload them later.
CodeDownload  
CREATE TABLE IF NOT EXISTS `phpf_eshop_dewar` like `phpf_eshop`;
INSERT `phpf_eshop_dewar` SELECT * FROM `phpf_eshop` WHERE `cid`=1;
Delete FROM `phpf_eshop` WHERE `cid`=1;

Falk has replied to this - 1 year ago
You can fix the search on line 47 in productsearch.php, change
CodeDownload  
$result1st = dbquery("SELECT * FROM ".DB_ESHOP." WHERE title LIKE '%$search%' ORDER BY ".$filter." ");

To
CodeDownload  
$result1st = dbquery("SELECT * FROM ".DB_ESHOP." WHERE active = '1' AND ".groupaccess('access')." AND title LIKE '%$search%' ORDER BY ".$filter." ");

MRKegtsc has replied to this - 1 year ago
Thanks. I've updated the productsearch.php on the server but it still doesn't exclude the `hidden` items from the search. I suspect I may be suffering from a cache problem because the code looks fine.

I've updated the previous post with the correct error message.
Thread Information
Author
Replies
273 posts
Views
66,544 times
Last Post
Last updated on 1 year ago
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.