Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

User login not working, and I can't add links to the main menu

I was able to install Fusion 9 without any apparent issues, but when I got my colleague to try logging in as a user, it created his account just fine but he can't log in. He doesn't get any errors either - it just puts him right back to the login prompt. I tried changing his password, and though the site says the settings were saved, he gets a password error if he tried to log in with that. If he uses his original, it goes back to just looping back to the login.

I also tried changing a few things about the site, and while some work, others don't. I was able to change the opening page from home.php to infusions/news/news.php just fine, but when I tried to add a link to the forums infusion to the main menu through site links, it wouldn't allow me to add a new link or change the existing ones. I could however, delete links. I noticed a few errors in the log, so I've attached them for reference...
grimmcartel attached the following file:
fusion9error.png [63.95kB / 135 Downloads]
Well, it looks like he is activated to me - maybe I am missing something?
grimmcartel attached the following file:
register.png [8.21kB / 78 Downloads]
user.png [32.07kB / 76 Downloads]
On the issue of the Site Links - it seems that it won't save settings unless I have the link set to be something other than "Public". If I set it to "Members", it saves just fine.
Hello, the site links is tested again. All permissions - 'link_visibility', 'news_access', 'forum_access', etc column should be standard:

TINYINT(4) NOT NULL DEFAULT '0', --- unsigned cannot be checked.

Please verify in SQL (PHPMYADMIN) your ___sitelinks table in phpmyadmin > structure > link_visibility row -- edit and reflect the correct
column type/attributes/default values and unsigned unchecked. Please see screenshot.

Which PHP-Fusion version are you using? 9.00 or 9.01
Chan attached the following file:
sql_table.jpg [49.04kB / 77 Downloads]
I think my config looks ok - I've attached the screenshot.

I'm using whatever version was available a few weeks ago through sourceforge. I think 9.0...
grimmcartel attached the following file:
sitelinks.png [52.64kB / 77 Downloads]
Please try this package: https://github.com/php-fusion/PHP-Fusion/archive/9.01.zip
Ok, well I just installed 9.01, and though it seems to set up just fine, and I didn't get any errors, it's still impossible for new users to register. I've included a screenshot with the new error
grimmcartel attached the following file:
fusion901.jpg [30.57kB / 77 Downloads]
Registration bug confirmed, give me a couple of hours to identify and fix.
Now the problem should fix. Please check if any problem continues

https://github.com/php-fusion/PHP-Fusion/commit/34557d5623bb7e458331b9825a5da9d1eb7128b3
Did you get activation email?

Go to Registration, set everything to No except for Use Registration System.
Just so we are clear, I had the email option set to no as well - the only thing active was enabling user registration.
Reupload these folders and try again. I'm sure it's working.

includes/
templates/global/
I don't see the templates/global directory?
grimmcartel attached the following file:
includes.png [36.6kB / 81 Downloads]
Seems to be working for logins/registration - I will test the rest.

Thanks for the help
Looks like I spoke too soon. My colleague just tried logging in to his new account on IE, and it just cycled back to the main page. He can log in and out in Firefox just fine though. Any idea why this might be?
Try to disable the IE history saving memory. It makes bněkdy problems due prohlížřečů and cache.
So, to get this straight. are you saying there is a general problem with IE and login?
What versions are you using if that is the case?
I tested the issue with IE 11 now ( fresh version ) issue confirmed. Login is not operational. It naturally need to change, issued : https://github.com/php-fusion/PHP-Fusion/issues/947
Start with IE Security Settings set to Lowest. Slowly increase. Then please report back?
I just noticed, my IE was maxiumum default, naturally login can´t wotk with no cookies. Put it to normal and it works..
Thread Information
Author
Replies
20 posts
Views
3,054 times
Last Post
Last updated on 3 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, Kvido, Chan, grimmcartel