Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Welcome to the Official Site of PHP-Fusion
Sign In
Not a member yet? Click here to register.
Navigation
10 Replies | Latest reply on 28-09-2017 05:52 by zizub
Chan
Chan Posted 1 year ago 3478 posts

SEO update

I've made increment on Github for 9.02 on all fixes on SEO I could find last hour. I'm not sure if I have covered it all or it will have bugs. But be sure to check it out. There are many faulty issues that has been fixed.

10 Replies

Sort replies by
Kamillo
KamilloPosted 1 year ago 230 posts
Let us make sure, that without login:
- links in forums are not visible by default
- in comments as well
- profile and links as well

That is bad seo, that takes spammers to make thaire posts/profile indexed.
Chan
ChanPosted 1 year ago 3478 posts
If I'm not wrong, Links are handled by bbcode. both url and autolink. For autolink, it's no index by default, non settings. For url, you can control.via ACP.

See the new parse_textarea - the all in one parse function, set to TRUE in bbcode parsing and autolink should kick in. They are hardcoded.
Kvido
KvidoPosted 1 year ago 480 posts
Hello!
Administration (Artemis) / SystemAdmin / Permalinks - SEO does not display settings, see. picture.

Merged on Dec 13 2016 at 13:43:03:
Update Git December 13, 2016 - 12:10
Permalinks are well displayed, see image and work. SEO links OK!

Just a mistake. HomePage on the header frame contains the code (??).
Kvido attached the following file:
phpf_seo_pc-politikacz_error.png [63.17kB / 1 Downloads]
phpf_seo_pc-politikacz_permalink_ok.png [104.16kB / 0 Downloads]
zizub
zizubPosted 1 year ago 99 posts
I have like all is good. Debug mode CEOs reveals red:
1. blogs / 3 / uidzhi.-prokljatie-doski-d-javola: No matching Alias found.
2. blogs / 3 / uidzhi.-prokljatie-doski-d-javola: No matching Alias Pattern found.
Kvido
KvidoPosted 1 year ago 480 posts
In your .htaccess commented:
# Options-Indexes
zizub
zizubPosted 1 year ago 99 posts

Quote

In your .htaccess commented:
# Options-Indexes
- by Kvido

My htaccess file looks like this:

Quote

# Force utf-8 charset
AddDefaultCharset utf-8

# Security
ServerSignature Off

# Secure htaccess file
<Files .htaccess>
order allow,deny
deny from all
</Files>

# Protect config.php
<Files config.php>
order allow,deny
deny from all
</Files>

# Block Nasty Bots
<IfModule mod_setenvifno.c>
SetEnvIfNoCase ^User-Agent$ .*(craftbot|download|extract|stripper|sucker|ninja|clshttp|webspider|leacher|collector|grabber|webpictures) HTTP_SAFE_BADBOT
SetEnvIfNoCase ^User-Agent$ .*(libwww-perl|aesop_com_spiderman) HTTP_SAFE_BADBOT
Deny from env=HTTP_SAFE_BADBOT
</IfModule>

# Disable directory listing
Options -Indexes

Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
# Let PHP know mod_rewrite is enabled
<IfModule mod_env.c>
SetEnv MOD_REWRITE On
</IfModule>
RewriteEngine On
RewriteBase /fusion9/
# Fix Apache internal dummy connections from breaking [(site_url)] cache
RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
RewriteRule .* - [F,L]
# Exclude /assets and /manager directories and images from rewrite rules
RewriteRule ^(administration|themes)/*$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteCond %{REQUEST_URI} !^/(administration|config|index.php)
RewriteRule ^(.*?)$ index.php [L]
</IfModule>
Kvido
KvidoPosted 1 year ago 480 posts
IfModule mod_rewrite.c should be like this.
Try, if it helps.
# Disable directory listing
# Options-Indexes

#Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
   # Let PHP know mod_rewrite is enabled
   <IfModule mod_env.c>
      SetEnv MOD_REWRITE On
   </IfModule>
   RewriteEngine On
   RewriteBase /
   # Fix Apache internal dummy connections from breaking [(site_url)] cache
   RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
   RewriteRule .* - [F,L]
   # Exclude /assets and /manager directories and images from rewrite rules
   RewriteRule ^(administration|themes)/*$ - [L]
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteCond %{REQUEST_FILENAME} !-l
   RewriteCond %{REQUEST_URI} !^/(administration|config|index.php)
   RewriteRule ^(.*?)$ index.php [L]
</IfModule>
zizub
zizubPosted 1 year ago 99 posts
Kvido - Thanks for the answer. I have tried the your option # Options but I have it not work. I'm testing on XAMPP localhost. When you try to open the site, I get a redirect to a page XAMPP __http://localhost/dashboard/

I little knowledge of SEO links. But maybe this error is uncritical, if she not visible for website visitors, turning off her in the admin panel / settings permalinks / SEO Enable debug mode:?

When you attempt to Disable SEO debug mode: / in, Permanent Links parameters, I got an error message - An error has occurred. It happens rarely. The message in the error log both in the this topic - http://www.php-fusion.co.uk/forum/viewthread.php?thread_id=38090&pid=200907#post_200907
Kvido
KvidoPosted 1 year ago 480 posts
@zizub
Hello!
1 / operation lolcalhost XAMPP is quite unreliable, but it should work.
2 / The version of PHP and MySQL you use, it is important to PHP should be more than the version of PHP 3.5
3 / I'm sending you a private message via PM my .htaccess. Copy this file and see.
zizub
zizubPosted 1 year ago 99 posts
Kvido - Hello! I replied to the PM.

Actions

Sharing

More topics like this

You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Users who participated in discussion: : Kvido, Chan, Kamillo, zizub
Chan

SEO update
by Chan Posted 1 year ago