Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
Hi,
My website quite working good for a year.
Now strange problem appear. Whenever i try to add news, it redirect to the main page.
That is : ?aid=xxxxxxxxxxxc key not working.

How May I correct this errror

9 replies

Is your admin rights working?
I can log in admin area and add news section also.
But redirection occur when I try to add news.
What is your PHP Fusion Version?

Check your site path. Is your site path correct?
I am using version v7.02.07
Site path is unchanged since installation. The problem is occurring for last month.
I am attaching path setting
subodh attached the following file:
untitled_7.png [7.1kB / 10 Downloads]
We'll try 2 fold solution:

Take this file : https://github.com/php-fusion/PHP-Fusion/blob/7.02.07/administration/news.php

Replace this file and check if the file is correctly uploaded.

Also, run this code anywhere before : https://github.com/php-fusion/PHP-Fusion/blob/7.02.07/administration/news.php#L292

Copy and Paste in:

// Function to check aidlink consistency
function run_me() {
global $aidlink;
if (!empty($_GET['aid']) {
$current_system_aid = $_GET['aid'];
} else {
die('NO AID');
}
echo "<strong>iAUTH</strong> now is ".iAUTH."<br/>\n";
echo "<strong>AID now is</strong> now is ".$_GET['aid']."<br/>\n";
if (iAUTH != $_GET['aid']) {
echo "You got a problem with IAUTH keys.";
} else {

// now check your redirect path
$redirect_path = FUSION_SELF.$aidlink;
echo "<strong>$redirect_path</strong>\n<br/> is correct?";

}
}
// run the function
run_me();


1. Check your administrator account . User Level must be 103,
2. Your redirect path is correct or not finally.
3. You need to find the redirect() function and comment it with 2 double forward slash "//" as well to run the test when Post here:
https://github.com/php-fusion/PHP-Fusion/blob/7.02.07/administration/news.php#L150
https://github.com/php-fusion/PHP-Fusion/blob/7.02.07/administration/news.php#L143

If it is still redirecting, there MIGHT be a panel running that is hindering you from posting. Disable all panels and try again.
I tried it. It gives me blank page. When clicking on "administration/news.php"
I have ensured that I have followed all your instruction.
I have tested I can add articles and extra pages. Problem only lies with news.

Merged on Apr 02 2017 at 05:05:32:
I have tried fresh installation. It also gives the same error.
I cant add news
See if your host changed PHP Version, maybe you can downgrade it some? around 5.5 should work. Fusion 7 won´t run to well on the latest PHP Versions.
Did you try with a default theme like Gilette? I have similar problems with non default themes.
Yes , I have tried fresh installation and still get the error. I think it's problem with server. But I cant get any error log file so I can get the idea.
News addition can be done via member submission. It's only problem with "administration/news.php"
No files have been altered. I have tested with fresh install.
author subodh
forumContent Administration - 8
replies10 posts
viewed2157 times
activeLast updated on 2 years ago

Related

Removing "news by"
Started by
R
rodpod - 3 posts
"News box" above at all other. How 2 do it?
Started by
T
temp_acc - 5 posts
News date instead modify date - possible?
Started by
P
pavka - 3 posts
NEWS.PHP AND NEWS_CATS.PHP
Started by
T
TRULYMI - 1 post
How to change news.php file to index.php or home.php file
Started by
P
prashant - 2 posts
News "last edited by"
Started by
H
Halle - 2 posts

Hot Questions

noob
SEO url rewrite
noob - 19 posts
Dawan
M
How to add my site at google?
Memberz - 31 posts
T
Admin Panel
tris_hill - 10 posts
atmalikasanli
How to remove copyright?
atmalikasanli - 9 posts
A
Remove News Panel?
atom6 - 13 posts
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Users who participated in discussion: Falk, subodh, Wanabo, Chan