Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Admin Links / Posts not working properly

Hi,

First i would like to say great work on php-fusion 9 a great improvement over 7!

I have just completed a fresh install on my server (php7) and everything went smoothly, except after i logged in and tried to access the admin panel... the link didnt work it would load as it it was working then it would redirect to home.php. If i were to right click on the link and open new tab, the link would work. this issue is all in the admin section and the aid is displaying in the address bar / when i highlight over a link. im also experiencing this issue when i try to save any settings (post) in the admin section.

Let me know if you need anymore info..

Thanks in advance!
Hi,
Thank you,
First, do you run latest Git version or is it the Rc 4 download you use? ( You need to use Git version at this stage )
hi thank you for your quick reply. I did use the latest git hub version as of this last sunday 4/23/17.

should i download the latest from today and give it another shot?
Yes, please do. Many fixes / changes have been implemented the last few days.
okay so i have just completed uploading all of the latest files from github, and now i am unable to access the admin panel at all even if i try opening with a new tab.


edit - after numerous attempts i was able to get to the admin login screen and login.. but i still get kicked out when i try to click on any admin links.
Clear your browser cache. It will log you out automatically, relogin. Problem will be gone.
I had read that in a post somewhere as well and that didnt work either.. i cleared cookies and cache, closed and reopened browser and even logged in from a different pc on a different network. I found that it is only the admin section as the install was fine, and i am able to send private messages.
There must be something with your local server environment, or are you on a real production server?
Do you have any errors, notices?
I was thinking that maybe there is something like rewrite not turned on but admin panel I believe doesn't use that... Also its only the admin panel... Normal site links and functions work..

But to answer your question it's technically on my production server but in my development section. I have been having issues with php Fusion 9 and getting it installed on my development (wamp). (think there is an issue with my mysql driver, but I haven't looked at it since I'll only be using that when I develop / convert some of my old infusions.

Do you think it could be an issue on my production because I'm using mysqli instead of pdo?
Thank you, but this part then?,

Quote

Do you have any errors, notices?

If you can just change to PDO in config.php and see what happens.
CodeDownload  
$pdo_enabled = 1;



I tested with mysqli now and I could still not reproduce this error, with no error logs or anything else to go in it is very hard to say anything more about it.
sorry i missed that... no errors are being displayed on the site and i checked the system logs with no errorrs either.. i changed the pdo to 1 in config cleared my cookies and cache and still have the same issue :/
Ok so i dumped the DB and reinstalled php fusion with the latest files, and i came across the same issue...however one thing i do notice is where it shows "users online" i see my user name 4x as online. then when i go and click on the admin panel link and it directs me back to home.php, i look at the "users online panel" and then i see 5x my user name. but i only have 1 browser window opened...

So when i reinstalled i noticed this error.. (see attached image) for apache and mod rewite.. I contacted my host and they confirmed that i have apache 2.4 and mod rewite is enabled... so this then led me to add a php info file on the site to see what is enabled / disabled...

tevoboard.com/info.php
diesltek710 attached the following file:
php-fusion-install-error-apache.png [129.98kB / 71 Downloads]
I am guessing it can have to do with the session,

Quote

Registered save handlers : files user

See if they can add,

Quote

mm + memcache
Just spoke with them and they are unable to do memcache for me... they are working on opcache tho, and double checking the mod rewrite.

so i cant get memcache installed tho.. so what would that mean? I wont be able to use ver9?

Thanks again for all your help and being patient with me.
I am not sure what is causing those issues for you, we never had them during the whole test period before.
Perhaps when we launch new Main we can offer a better hosting deal for you that can run 9 if you would be intressted.
Install phase explanations

PHP Fusion 9 does not require memcache. It is still in my #todo-roadmap.
Those severability detection during installation is just a gauge how well your PHP-Fusion CMS 9 in your server.

Local production server

I can't say for WAMP, but I recommend using XAMPP with the latest version PHP 7.1.1 (the copy that were used by our core developers building the PHP-Fusion 9).

3. Now to the issue:

If you can login to the admin panel, and every subsequent link gets you kicked out of admin, then it is definitely cookie issue. Test with a different browser if you are not sure whether you have cleared your cookie correctly just to oust this possibility.

However, If a single f5 refresh gets you kicked out, then $aidlink generator may be mismatching your site credentials.
Check your site path in settings and make sure your site path is the current directory path.

It will also help if you go to recovery console (install.php) and change super administrator settings with new password, admin password as a last resort. It will not harm your entry records whatsoever.
I have try a Little bit and has the same Problems on admin Login with my mobile phone.
On Laptop no Problems but on my phone sometimes i come into admin area and if i click some in it, i get Redirect to home.php

Greatz
Okay so to put to rest issues with my host i upgraded to a virtual cloud server and have configured the server, and reinstalled php fusion... only for it to work for it to work first try then kicked out and havnt been able to access the admin panel again. but.. this time i get an error.

CodeDownload  
MySQLi.inc
/home.php
Line: 187
6 seconds ago



then i tried Edge browser again and it works fine and no errors.. so it seems that after switching servers, i finally atleast got it to work on a browser vs none like before.. but i wonder why chrome is giving ME and issue :/
Clear your cache in Chrome. In Full, except Passwords. Talking about downside of being fast. It doesn't pull anything from the server on second and subsequent reloads of any site url that it has previously visit.
Hey Chan thanks for helping out. I have cleared my cache and cookies every times, even tried incognito mode, and a different pc. I'm getting this error in edge as well.. but everything seems to be functioning properly for the most part on that browser except for the forums..

but i think that it will be a different thread but first ill have to search around and see if anyone else has that issue as me.

The error im getting in Edge, and chrome when it wants to work is
CodeDownload  
MySQLi.inc
/infusions/forum/viewthread.php?thread_id=1&pid=2
Line: 187



that same line on any page i go on the site.. maybe chrome has a different way it handles the error and doesn't do anything and edge just goes along with it?

This is the line in the cord
CodeDownload  
   if (!$result) {

            trigger_error(mysqli_error($this->connection)." <strong>@ ".$query."</strong>", E_USER_NOTICE);

        }

Thread Information
Author
Replies
25 posts
Views
4,675 times
Last Post
Last updated on 2 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, Chan, diesltek710, WuChEn