Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Two errors in PHP-Fusion 7.03.00

douwe_yntema - Latest reply on 11-11-2018 16:39 by afoster

0

douwe_yntema
douwe_yntema
On my site with PHP-Fusiob 7.03.00 I Discovered 2 errors I am not able to solve:

1 - When the locale is NOT set to English, an error occurs when editing an email template from the control panel. An error message is thrown and the template is not showing up. When locale is set to English, everything is working fine. The errors in the error log are:

Quote

includes/theme_functions_include.php
Undefined offset: 0 Regel: 464
administration/email.php
Undefined offset: 1 Regel: 99


In language settings language settings are enabled for e-mail templates. When language settings are NOT enabled for email template, the template is showing up, with only the first error in the error log.

2 - When submitting a file download as member (not in the admin panel) the submitted file and screenshot are not stored on the server. The following errors are reported in the error log:

Quote

public_html/submit.php
Undefined index: download_filesize Regel: 242
public_html/submit.php
Undefined index: download_file Regel: 244
public_html/submit.php
Undefined index: download_image Regel: 245


It seems to be someting is forgotten to code in the submit.php. As said the files are not stored on the server, but the data is available in the table submissions, but not the url for the file and the screenshot.

As 7.03.00 is not officially supported, I hope someone can help me solve these 2 things I can't

Sort replies by

0

afoster
afoster
Is version 7.03.00 downloadable somewhere?

0

afoster
afoster
Tried to upload a new theme but having display problems. Can you check http://www.bonanifamily.com/follies/ and tell me what is causing the subheader bar to display as it is? Thanks.

0

Falk
Falk
The system is pretty straight forward.

1, Check so the email templates have a language table.
2, Make sure the selected language are inserted to the created table that store languages.
3, Make sure the query is polling the correct table for language.

@afoster
Looks ok now (? )
afoster has replied to this - 1 month ago

0

afoster
afoster
Yes, it looks OK now because I changed it back to the one that was working. I received a response from the developer of version 7.03.00 and was told that not all themes that worked for 7.02.07 would work for 7.03.00 so I changed it back.
Actions
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Participated Users

Moderators:
{%user_avatar%}

Two errors in PHP-Fusion 7.03.00
by {%user_profile_link%} {%post_date%}