Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

What is it in PHP 5.6 that screws up High ASCII?

I can meddle a bit with my host settings and I appreciate the option to be able to do that.

For years I have, on and off, dreaded any mayor changes or upgrades to PHP-Fusion on sites with High Ascii Characters. Unicode was introduced to deal with that, but still, when I step by step switch from PHP 5.1->5.2->5.3->5.4->5.5 and to 5.6 it screws it up at 5.6.

The language files are UTF8 -bom, as we have discussed here many times, the database collation is set to UTF8MB4_unicode_ci, which works and the collation of tables are set to latin1_swedish_ci which has also worked so far with all upgrades from PHP-Fusion 7 to 7.02.07.

Now I am about to launch a new system that requires minimum PHP 5.6 and I am prepared to change the table collation but the strange issue is that the change of PHP does not seem to affect High ASCII everywhere. It seems to err on texts located in

- News Titles
- Administration links, including text buttons
- Site title
- Menu links (header as well as navigation bar)

and a few more places but oddly enough not in TEXT fields, bread text.

One would perhaps suspect the language files if it weren't for the entries in menus and other non lang depending places.

I can change those from latin1 to utf8mb4 but it makes no difference. And now we seem to have a gazillion of UTF8 options to choose from in PHPMyAdmin which makes things soo much easier. Not.

Tips?

The site is www.eslovsmoderaterna.se but i can not leave it on with the flaws to show...
You always need to harmonize file formats cross the board, or it will fail. File format, Charset, Database must be compatible / same and it will work.
As to the title, idk never looked it up, just fix it when needed.. I preferably downgrade PHP version.
Can't downgrade. Rather the opposite is urgently needed. Not going to start micromanaging code, when no relevant code was ever altered, will also screw up upgrades.
It use UTF-8 default, force a new charset, try this in maincore,
CodeDownload  
ini_set("default_charset", "ISO-8859-1");


or .htaccess.
CodeDownload  
php_value default_charset None
AddDefaultCharset ISO-8859-1



or edit the php.ini and turn off default charset.
Here is the key to your solution anyway.
Thread Information
Author
Posted In
Replies
4 posts
Views
1,648 times
Last Post
Last updated on 2 years ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, Homdax