Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Bizzare Infusion Problem on 7.02.07


Print Track
I will try to explain my very strange problem with my Classified Ads infusion. Ever since I finally upgraded my main site whisperwillow.com to 7.02.07 I have been slowly re-doing all my infusions to get everything error free in this cms version. I have been debugging and recoding my Classified Ads for about 2 weeks now. I had everything totally error free and working great. When I went to bed last night at about 1am everything was working flawlessly. When I got up this morning to resume it won't work anymore. When I click on my link for classified_ads.php (or change the address bar to point to any other page in the infusion), all I get is a blank white page. View page source shows only the header info from the theme and it ends with <body>. I have scrutinized every single script and have changed the server php version to lower versions from 5.5 and NOTHING I have done has helped. I am at a total loss as to what to do here. I have never encountered such a bizarre thing in my coding lifetime except once when I had omitted a semi-colon on a locale entry. I have no other info to tell or show; there are no server errors, no system errors nothing!! Maybe this has happened to someone else before. All I can do is hope.
Falk has replied to this - 1 year ago

7 replies

I have observed similar behaviour in some environments where it goes blank because heders is already sent. The error message will however not display. You get a white blank page.
You can correct it by checking chains of includes, even remove some includes just to debug. If you find it, see if it have any theme include extra in it like header where it should not be because it has already been loaded before, etc
Grimloch has replied to this - 1 year ago
Do a syntax check on your files
@Falk: Every other infusion works fine; my whole site works fine except for this infusion which was working when I went to bed. Here is the view page sourcre when clicking the infusion link:
CodeDownload  

<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Transitional//EN' 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd'>
<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
<head>
<title>WhisperWillow PHP-Fusion Mod Support</title>
<meta http-equiv='Content-Type' content='text/html; charset=iso-8859-1' />
<meta name='description' content='WhisperWillow PHP-Fusion Mod Support Site is aimed at providing support for infusions, themes, panels and mods that I have created for the PHP-Fusion version 7 CMS system. Where possible support is provided for other peoples work also.' />
<meta name='keywords' content='PHP-Fusion, CMS, Content Management System, Open Source, PHP, MySQL, HTML, Infusions, Mods, Modules, Portal, Portals, PHP Scripts, CMS Software, Software, Code, Coding, Code Snippets, Webmaster, Javascript, Java, Themes, Forums, Coding Help, Technical Support, PHP-Fusion Customizing, PHP-Fusion Themes, PHP-Fusion Infusions, PHP-Fusion Mods' />
<link rel='stylesheet' href='../../themes/TLC/styles.css' type='text/css' media='screen' />
<link rel='shortcut icon' href='../../images/favicon.ico' type='image/x-icon' />
<script type='text/javascript' src='../../includes/jquery/jquery.js'></script>
<script type='text/javascript' src='../../includes/jscript.js'></script>
<script language='javascript1.2' type='text/javascript'>
function openjukebox (URL, WindowName, Features)
{
window.open(URL, WindowName, Features);
}
</script>
</head>
<body>


As you can see it doesn't even load the includes from the top of the infusion script which are here:
CodeDownload  

require_once "../../maincore.php";
require_once THEMES."templates/header.php";
if (file_exists(INFUSIONS."classified_ads_panel/locale/".$settings['locale'].".php")) {
   include INFUSIONS."classified_ads_panel/locale/".$settings['locale'].".php";
} else {
   include INFUSIONS."classified_ads_panel/locale/English.php";
}
include INFUSIONS."classified_ads_panel/infusion_db.php";
include INFUSIONS."classified_ads_panel/include/functions_include.php";


This is what's supposed to be there from the functions include script:
CodeDownload  

add_to_head("<link rel='stylesheet' href='".INFUSIONS."classified_ads_panel/include/ads_style.css' type='text/css' />");
add_to_head("<link rel='stylesheet' href='".INFUSIONS."classified_ads_panel/include/balloontip.css' type='text/css' />");


I am using the same host that you are; A2.

Merged on 06/10/2018:
@douwe: Are you speaking of a visual syntax check or some utility that you use?
I mostly use this one (if not on linux)
https://nl.piliapp.com/php-syntax-check/
Also I have another 7.02.07 site www.fortworthbonsai.org which also runs Classified Ads. It's on Blue Host. I manually updated the database tables for Classified Ads with infusion changes, deleted the 'infusions/classified_ads_panel' folder and re-uploaded the entire infusion folder from my re-worked/re-coded infusion and it works flawlessly so I don't suspect any coding or syntax errors. I remain totally baffled by this result.
I tried to infuse a copy of your Classified Ads infusion and evidently I have an older copy as the database creation still had TYPE=MyISAM but once I changed it to ENGINE=MyISAM, it infused with no problems and displayed on the main page of the site. However, when working on the settings, it did not keep any of the three bottom settings where you can enter Yes or No to the questions. Also, when trying to place an ad, there were no users listed in the drop down menu. I did this on my test site which has about 8 members.

Don't know if that helps or not with your problem...and yes, I am using version 7.02.07 on my test site.
Afoster: You still don't have the newer corrected version of Classifieds no matter where you got it. I'll zip it up and send it to you via snail mail.
cool

Merged on 06/10/2018:
OK some further info and testing results. I cleared my Firefox cache, I tried Chrome and Edge with the same results. I tried it from my Win7 computer with the same result. I sent afoster the zip, he installed it (I think he uses iPower Host); I get the same result there. All of this seems to eliminate browsers, operating systems and hosts. Could someone PLEASE install this and check it out from a completely different perspective? Remember you must create at least 1 Section Title with 1 Category under that title to be able to post an ad. Thanks in advance.

I have removed the attachment. I found the problems and am going forward from here. To anyone that may have d/l'ed the attachment no need for testing; just delete it cause it won't work. Sorry for the inconvenience I may have caused. Once I finalize everything this infusion will be available for d/l on my main site. Thanks.
author Grimloch
forumPanels and Infusions
replies8 posts
viewed834 times
activeLast updated on 1 year ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, afoster, Grimloch, douwe_yntema