Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
batbaru1

Admin password not working after V7.02.07 upgrade to V8

by batbaru1, Last updated on 3 months ago in Upgrading issues - 8
Hello,

I downloaded the advertised PhP-Fusion v8 at https://sourceforge.net/projects/php-fusion/files/PHP-Fusion%20Archives/8.x/PHP-Fusion%208.00.00.zip/download. I installed per the readme and all seems to have gone well and I am running on V8 and pon PHP7.2. But after the upgrade, I logged out then back in, then to admin panel it prompted me for my admin password. The admin password I have always used doesn't work and I wasn't prompted anywhere in the upgrade process to enter (change?) any password. Can anyone help?

Sorry if this is a duplicate help request from another post. I thought I saw someone post about it before but cannot find it in search. Help!
Heya,
Try to only use like only small letters, only large letters etc.
8 does not change passwords but it are picky on large/small letters as they where written when the password was created..
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
My admin password is all lower case letters and numbers, and is the password that was working on v7.02.07 before my upgrade attempt. I did the upgrade to v8 and I can login fine using my normal user password. But the admin password no longer works now that it is required to get to the admin panel.
It really does nothing to the passwords so it is odd, but follow this : Lost Admin Password and your passwords will be new and you can set a new one.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
Is it the normal login not working for the admin or the admin password not working?

Normal login is the same for user and admins. If as admin going to control panel, a second password must be entered. Same as for old skool 7.02.07 e.g. when change panels.

When logged on as admin, via profile page admin password can be set.
The world is full of kings and queens
Who blind your eyes and steal your dreams
It's heaven and hell
- Black Sabbath
batbaru1 has replied to this - 3 months ago

Quote

. If as admin going to control panel, a second password must be entered. Same as for old skool 7.02.07 e.g. when change panels.

Should not be the case in 8. It does an extra check if the password is there, but does not ask for it again.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
V8 does check for admin password. But only once and every time when logged in.
The world is full of kings and queens
Who blind your eyes and steal your dreams
It's heaven and hell
- Black Sabbath
oh, Maybe I read it wrong. You had me on same as old school. Well yes a one time login only, never once inside the admin is the correct order wink
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)

Falk wrote:

@Falk - It really does nothing to the passwords so it is odd, but follow this : Lost Admin Password and your passwords will be new and you can set a new one.

Thanks, I didn't think to try that. I rolled back to v7.02.07 from backups when I couldn't get in as admin after the upgrade. Will try again this weekend.

Merged on 01/04/2019:

douwe_yntema wrote:

@douwe_yntema - Is it the normal login not working for the admin or the admin password not working?

Normal login is the same for user and admins. If as admin going to control panel, a second password must be entered. Same as for old skool 7.02.07 e.g. when change panels.

When logged on as admin, via profile page admin password can be set.

The normal login works normally both before and after the upgrade to v8. The admin password, working on v7.02.07, would not work once I did the upgrade to v8 and the admin password is prompted for before getting to the admin panel/control panel. After a day of going nowhere with it I ended up restoring v7.02.07 from backups and the same non-working admin password in v8 still/again works when rolled back to v7.02.07.
If you read https://www.php-fusion.co.uk/infusion...ost_205730 It help you to restore it in 8 as well. Like I said, 8 does not change passwords or touch the password tables at all. However it is more picky on how it was written, that is the only differance.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
I will try the v8.00.19 update and see if I can get thru the update from v7.02.07.
Best of luck, however it should work fine for you.
21+ days later we have not seen any similar Admin pw issues as you describe, If you still struggle with it you must follow my instructions that I linked two posts above this one to reset it.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
Thanks for the Ddraig theme in v8.00.19! smile
7,02.07 > 8.00.00

Admin pwd issues as described above... Tried the link you posted Falk , but it would not take it. Tried other browser for another session.

Maybe if you give me the function setting in the table? Where is the DB Schema? Or still MD5?

EDIT/ never mind I got in.
I disabled Maintenance in Database, then made a pwd reset request using normal function for that and got in the site and then it took the 123456789 admin password set i database.
So if you look for a clue to this I think it may be in the USER password management, somehow.

EDIT 2
The admin password shows as plain text when entering it... should it do that? Normally you would se ********** but not there
Need help? Having trouble?
» View our Documentation for guides, functions and more - including the Getting Started section!
» Attach Log Files and Screenshots when reporting issues
» Name and Organize your content correctly for best results - use good grammar

Who the hell thought "erectus" was a good species name for our ancestors?
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.