Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

function include gives warning

by , Last updated on 9 days ago in Suspected Bugs and Errors - 8
How to fix this?

Quote

Warning: include(locale//errors.php) [function.include]: failed to open stream: No such file or directory in /var/www/kidsvolley-kerteminde.dk/public_html/v8/includes/error_handling_include.php on line 22

Warning: include(locale//errors.php) [function.include]: failed to open stream: No such file or directory in /var/www/kidsvolley-kerteminde.dk/public_html/v8/includes/error_handling_include.php on line 22

Warning: include() [function.include]: Failed opening 'locale//errors.php' for inclusion (include_path='.') in /var/www/kidsvolley-kerteminde.dk/public_html/v8/includes/error_handling_include.php on line 22


line 22
include LOCALE.LOCALESET."errors.php";


And it is not possible to access the admin area ...
All people are born alike - except Republicans and Democrats.

Groucho Marx

-----------------------------------------

The system locale is blank, locale//errors.php < Should be locale/Your_lang/errors.php
How did it happend?
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
I followed the advice in this thread https://www.php-fusion.co.uk/infusion...ost_205767 to download utfcast and installed it on my old laptop

I converted all the Danish locale files and uploaded them to the v8-folder
after upload the error appeared and now you can't access admin area either
I reuploaded the backup files but still no website content
All people are born alike - except Republicans and Democrats.
Groucho Marx
-----------------------------------------
Ah, utfcast does not copy files not converted, if you only uploaded output from the utfcast it will miss files. But when I see the error, It looked like the $setting ['locale'] is blank. Maybe you can verify this.
phpMyAdmin > Table > Settings > Find PREFIX_settings > locale and see if it says Danish.
Falk attached the following image:
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
it says Danish
helmuth attached the following image:
All people are born alike - except Republicans and Democrats.
Groucho Marx
-----------------------------------------
Falk has replied to this - 9 days ago
Only thing I can think of is that you added BOM, see the check mark. It is Write BOM default.. It must be unchecked or the files will get corrupt.
Falk attached the following image:
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
I'm quite certain that is was unchecked ...
All people are born alike - except Republicans and Democrats.
Groucho Marx
-----------------------------------------
I think we have a version mixup here, earlier versions had a admin_language sneaked in to the Github, this was not good for compatbility and it will crash the site unless the table exist in the PREFIX_admin strcuture.
This one does not exist now ( I removed it yesterday ). So if you have an older Git version, try a new copy. The current copy is pending for an release when I figured out what afoster has issue with.. But it has been tested in local xamp, laragon, live servers. Here and my private ones on a large varyity of environments. Ubuntu, IIS, Apache, PHP 7.1.11 > 7.2.13 etc etc.. it feels very solid but I wanna see if we have something extra to sort before a release.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.