Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Registration Issue

I keep getting an Internal Server Error when trying to register a new member. I have removed the Gateway option as I remember reading that was a problem.

In looking at my error log on my webhost, this error is being thrown when trying to register a new member:

20190107T155139: domain.com/fusionv8/register.php
PHP Fatal error: Call to undefined function form_sanitizer() in /myhost/webhost18a/b105/ipw.domain/public_html/fusionv8/includes/captchas/securimage3/captcha_check.php on line 25
It has been patched : https://github.com/php-fusion/PHP-Fusion/commit/2f35631a5c4d5315b4362566c1d3e667e6c948f8 , Ty !
I am no longer getting the error message, but no matter how many times I enter the Validation Code, it keeps telling me that it is incorrect. Is there a way to bypass entering the code?
Fixed https://github.com/php-fusion/PHP-Fusion/commit/d24e30a481b0c561205420d76bc4d18de0d4e736
afoster has replied to this - 9 months ago

RobiNN wrote:

@RobiNN - Fixed https://github.com/php-fusion/PHP-Fusion/commit/d24e30a481b0c561205420d76bc4d18de0d4e736


That did not fix it...it is still not letting me register because of the Validation Code.
Yes, I have updated securimage and it is not working for me. Don't know what to do at this point.
The patches fixed the issue for me. :)

How did you apply the patch - That is - did you overwrite with the new files, or did you manually apply the changes? I did the latter and wondered why I had the same problem as you, but as it turns out, I had removed too much from captcha_check.php.
I uploaded the revised file from github.com and still cannot get anyone registered. Not being able to get anyone registered pretty much makes this version unworkable for me. Not to mention that I can't get the external wrapper infusion to work either.
The problem is that it says that it has been infused, but there is admin page and it does not appear in the infusions list. I am using version 3.0 of the infusion and the newest version of php-fusion 8. Perhaps you can send me the one you are using so that I can try it on my site. You can send it to fredsfollies@outlook.com
I send you the infusion per mail
douwe_yntema, it works. Thanks so much for sending me your version. The only difference I can see is that I thought the wrapper version I had in version 7.02.07 could pull a page from another domain. The version you sent me only seems to work if the page is pulled from the domain I am using. Now if I can only get the registration issue resolved, I will be a happy camper. I am still not being allowed to register due to the reCaptcha3 not being read correctly.
The version I sent you can also pull from another domain, see my example.

But some websites has a blocking meganism built in for Iframe Access.

Maybe that is your issue
Evidently because when I tried to pull a page from another domain, I received an error message that stated that it cannot find the file. If that is my only problem with the wrapper, I can and will work around it. thanks again.

Merged on 01/11/2019:
I am getting an internal server error when trying to pull a file from a different domain using the wrapper infusion. Here is the error as shown in my cgi error log on my webhost:

PHP Fatal error: Call to undefined function stripBBCode() in /hermes/bosnaweb18a/b105/domain/public_html/fusion/infusions/wrapper/wrapper.php on line 95

Line 9t of wrapper.php is: opentable (stripBBCode($page_title));

Any ideas?
In v8 function strip_bbcodes is lowercase.
That is your problem.

Change capital to lowercase in wrapper infusion.

Same for all bbcode functions

Merged on 01/11/2019:
O and it should be strip_bbcodes, with an underscore

See file includes/bbcode_includes.php
After changing the code from capital lowercase in the wrapper infusion (yes, I added an underscore), I am still getting the Internal Server Error.
I am using the url from the other domain but adding "infusions/wrapper/wrapper.php?wrapper_id=0" in the Site Links area. What am I doing wrong? If the page is on the same domain, it is working.
Wrapper id of 0 is wrong. First id to be used is 1, see my example.

Can you give me the url you try to embed? I can try with my version.
Thread Information
Author
Replies
25 posts
Views
888 times
Last Post
Last updated on 8 months ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, afoster, Mickelvlm, douwe_yntema, RobiNN