Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Cannot Register New Members

by , Last updated on 3 months ago in Suspected Bugs and Errors - 8
I am so frustrated by this registration issue...I am using the "newer" version 8 and cannot get anyone registered. I don't know what happened between the original version 8 and this new one but I am hoping someone can help me. Please look at the attached screen shot that shows the Validation code and what I believe the code is. I keep getting the following error message:

Registration failed for the following reason(s):

Incorrect validation code.
Please Try Again.

I am assuming the validation code is case sensitive? My webhost is using php version 5.6.3
afoster attached the following image:
Latest v8 from Github.
Try the newer PHP and reupload again all files from Github.
snag.gy/4Jngsl.jpg
PHP-Fusion Development Manager
Web Designer/Developer: GitHub
It's not Fusion which is the issue, it's entering the correct validation code. It happened to me too when testing the registration system on V9.

ikandi wrote:

@ikandi - It's not Fusion which is the issue, it's entering the correct validation code. It happened to me too when testing the registration system on V9.


Are you saying that the validation code I entered in my screen shot is not the correct one? If not, what should it be?

Merged on 01/12/2019:

RobiNN wrote:

@RobiNN - Latest v8 from Github.
Try the newer PHP and reupload again all files from Github.
https://snag.gy/4Jngsl.jpg


I downloaded the newest version on January 9th...in looking at the files on github, it does not appear that there is a newer version.

Merged on 01/12/2019:
Further to this issue, I just noticed that the error log in php-fusion is showing the following 2 error messages after trying to register a member:

securimage3/securimage.php
session_start(): open(/var/php_sessions/sess_1251f1009a36cf63320f5bded8bbae37, O_RDWR) failed: No such file or directory (2) Line: 1168

Unknown
Unknown: open(/var/php_sessions/sess_1251f1009a36cf63320f5bded8bbae37, O_RDWR) failed: No such file or directory (2) Line: 0

This is after downloading the most recent files from github (this afternoon)
PHP Fusion crew: What the heck was wrong with 'secureimage2' ?? It seemed to always work just fine and was easier to decipher the letters/numbers. Why did you go to 'secureimage3' ??
Energy can neither be created nor destroyed; only transformed !
v2 does not work on new PHP 7.
And also in v3 lot of issues is fixed...
PHP-Fusion Development Manager
Web Designer/Developer: GitHub
In v2 you must change in securimage.php this:
function Securimage()
   {
      if (!defined("DB_PREFIX")) {
         require_once "../../../config.php";
         require_once "../../multisite_include.php";
         
         mysql_connect($db_host, $db_user, $db_pass);
         mysql_select_db($db_name);
      }


to:
function __construct() {
      if (!defined("DB_PREFIX")) {
         require_once "../../../maincore.php";
         //require_once "../../../config.php";
         require_once "../../multisite_include.php";
         //mysql_connect($db_host, $db_user, $db_pass);
         //mysql_select_db($db_name);
      }


That should work
Yes, I know this but there are still lot of issues.

I will add back v2. For people who are still use unsupported PHP 5.6
If is possible, use newer PHP.

Added back v2 https://github.com/php-fusion/PHP-Fus...6f3b4a48d4
PHP-Fusion Development Manager
Web Designer/Developer: GitHub
afoster has replied to this - 3 months ago

RobiNN wrote:

@RobiNN - Yes, I know this but there are still lot of issues.

I will add back v2. For people who are still use unsupported PHP 5.6
If is possible, use newer PHP.

Added back v2 https://github.com/php-fusion/PHP-Fusion/commit/ecd01aebbe32a8c8b3851e2c7554306f3b4a48d4


I don't have a choice about using the php version I have...Thanks for putting back v2 of captcha.
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Users who participated in discussion: afoster, Grimloch, Harlekin, RobiNN, ikandi