Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
djdandi

A serious problem. Suddenly the site has stopped working

by djdandi, Last updated on 3 months ago in Upgrading issues - 9
Hello, I have seen a strange problem on your site. Suddenly, it stopped working and instead of the page my data appeared from the config.php file type username, password and database name mysql. I have a PHP-Fusion 9.03 version and everything has been working nicely so far. The information below is displayed instead of the page. I deliberately changed the data in the config.php file.
How to fix it?

Fatal error: Uncaught Error: Class '\PHPFusion\Database\Driver\MySQLi' not found in /home/brzanek/public_html/02052018/includes/classes/PHPFusion/Database/DatabaseFactory.inc:222 Stack trace: #0 /home/brzanek/public_html/02052018/includes/db_handlers/all_functions_include.php(191): PHPFusion\Database\DatabaseFactory::connect('localhost', 'name', 'djdj', 'nazwa_bazy', Array) #1 /home/brzanek/public_html/02052018/maincore.php(39): dbconnect('localhost', 'name', 'djdj', 'nazwa_bazy') #2 /home/brzanek/public_html/02052018/index.php(18): require_once('/home/brzanek/p...') #3 {main} thrown in /home/brzanek/public_html/02052018/includes/classes/PHPFusion/Database/DatabaseFactory.inc on line 222 
See if you have this file root/includes/classes/PHPFusion/Database/Driver/MySQLi.inc
PHP-Fusion Development Manager
Web Designer/Developer: GitHub
Yes, I have this file
It also does not work on another page. I have a problem.
Fatal error: Uncaught ErrorException: SQLSTATE[HY000] [1045] Access denied for user 'brzanek_brzanek'@'wn19_2.int.webd' (using password: YES) in /home/brzanek/public_html/26022017/includes/classes/PHPFusion/Database/DatabaseFactory.inc:0 Stack trace: #0 /home/brzanek/public_html/26022017/includes/classes/PHPFusion/Database/AbstractDatabaseDriver.inc(70): PHPFusion\Database\Driver\PDOMySQL->connect('localhost', 'brzanek_brzanek', 'pass', 'brzanek_2602201...', Array) #1 /home/brzanek/public_html/26022017/includes/classes/PHPFusion/Database/DatabaseFactory.inc(219): PHPFusion\Database\AbstractDatabaseDriver->__construct('localhost', 'brzanek_brzanek', 'pass', 'brzanek_2602201...', Array) #2 /home/brzanek/public_html/26022017/includes/classes/PHPFusion/Database/DatabaseFactory.inc(178): PHPFusion\Database\DatabaseFactory::connect('localhost', 'brzanek_brzanek', 'pass', 'brzanek_2602201...', Array) #3 /home/brzanek/public_html/26022017/includes/db_handlers/all_functions_include.php(232): PHPFusion\Database\DatabaseFactory::get in /home/brzanek/public_html/26022017/includes/classes/PHPFusion/Database/DatabaseFactory.inc on line 0 
Sounds like your host made some configuration changes.
Make sure you change all usernames and passwords once resolved as well.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
But how can I bring the site to action. How to fix this problem.
These changes appeared to me probably after uploading a new thema
https://github.com/php-fusion/Themes/...s/Atom-XCP
I wanted to check the operation of this style but I forgot that I put it on my site. I turned it on in PA and switched off in a moment. After an hour I go to the site and here is the problem. I do not know if it has anything to do with it or not.
You have an idea how to restore the website.
That is an Admin Theme.
Only time you should experience something from it is when you enter your administration, other than that it never interact with your site´s front-end at all.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
I thought it did not affect the operation of the main page but I preferred to write and make sure.
I've rewritten the whole directory includes / classes / PHPFusion /
but it also did not help.
Double check with your host if any changes has been made to the environment. Admin Themes does not interfair with front-end unless you also update files in other sections.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
See if you have any backups prior to your update and use all core files from this one.
If these backups does not help an environment change are in effect and your host need to solve it.
Need help?, Having trouble?
• View our Documentation for Guides, Standards and Functions
• Name and Organize your content correctly in the corresponding Forums for best support results
• Attaching Log Files and Screenshots when reporting issues will help
• Please read and comply with the Code of Conduct

(¯`·._.·(¯`°·._.·°º*[ Project Manager ]*º°·._.·°´¯)·._.·´¯)
This line in files
admin_layout.php
core_functions_include.php
layout.php
$fusion_jquery_tags = \PHPFusion\Minifier::minify($fusion_jquery_tags, ['flaggedComments' => FALSE]);

I exchanged it for
//$fusion_jquery_tags = \PHPFusion\Minifier::minify($fusion_jquery_tags, ['flaggedComments' => FALSE]);

It was going to work
You can view all discussion threads in this forum.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Users who participated in discussion: Falk, djdandi, RobiNN