Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Upgrading from 8.00.19 - 8.00.21

I am fairly certain that I followed all of the directions in the readme file as to upgrading the php-version, the attached screenshot shows the error found in the error log of the admin module. Hopefully someone can provide assistance to fix it.
afoster attached the following image:
dberror.jpg
It seems to be an environment configuration issue. Since you had earlier version the mb4 should be ok anyway. You can remove the sql conversion and just let it update the database to correct version.
My apologies Falk, but I don't understand what you are suggesting I should do.
Try this one ( Admin folder ) smile
Falk attached the following file:
upgrade.zip [1.17kB / 62 Downloads]
Perfect, it eliminated the error in the error log. Now the only error I have in the log is

mysql_result() expects parameter 1 to be resource, object given

which applies to one of the infusions I am trying to get to work. Thanks for your help.
That is harcoded MySQL in the code. Since MySQL is not supported above PHP 5.6 it will be harder to maintain them codes. You can replace mysql_result with dbarray($result); pay attention so the $result matches initial query, it may be another $ variable that is requested.

Falk wrote:

@Falk - That is harcoded MySQL in the code. Since MySQL is not supported above PHP 5.6 it will be harder to maintain them codes. You can replace mysql_result with dbarray($result); pay attention so the $result matches initial query, it may be another $ variable that is requested.


Thanks for your response Falk. Replacing mysql_result with dbarray created other errors and I can't figure out what query $result matches. For an infusion that I can't get to work, I am thinking that it is not worth the hassle of trying to fix this error.
@afoster
Hey Fred which infusion are you having issues with? Maybe I can help?
Thanks Grimloch. The infusion is called autonews and I have it working on two different sites that use php-fusion 7.02.07. I am trying to adapt it to my php-fusion 8.00.21. I can get it infused, but I can't get it to send out emails as needed. I am attaching the infusion here in the hope that you can do something with it.
afoster attached the following file:
autonews_infusion1_1.zip [54.49kB / 47 Downloads]
Thread Information
Author
Replies
9 posts
Views
420 times
Last Post
Last updated on 9 months ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, afoster, Grimloch