Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

What have I done?


Print Track
I upgraded my site from v7 to v8 and when I did the database upgrade, everything was fine. but when I copied all the files over, it has been messed up.

here is a link
http://rf.vivalavoltz.com

Merged on 04/05/2019:
As of right now I added the v7 files back so the site can be readable.

Before it was just barebones text.

23 replies

I see no examples of what you experienced, the first thing that comes to my mind is that you perhaps do not meet the minimum requirements, please check them and your environment versions. (PHP, MySQL).
You couldn't see an example because went back and put the old files up so I could at least have the site up.

Here's the order I've done things:

-Have php-fusion version v7.02.07
-decide to update to v8.00.21
-read the instructions to upgrade from v7 to v8
-upload files from "Upgrade_7.02.07_8.00.21" to my root site folder
-go into admin panel and click update for the database
-alter the config.php file as it instructs
-Alter the upgrade.php file (line 135 change disabled = FALSE to disabled = TRUE)
-Everything seems ok so far. Admin panel now says v8.00.21
-I decide to complete the update by uploading the rest of the files into root folder. I'm not sure if this is the correct step. the readme is kind of vague.

Below is a screenshot of what I am dealing with now.

cupid.vivalavoltz.com/images/links_on_sites/phpfusion/phpv7tov8issue.png
http://rf.vivalavoltz.com
A link is above and it's currently messed up.
Imho, the readme is step by step idk what else could be added to make it more clear. Any suggestions?.
Anyway, delete the .htaccess file it seems your environment does not like the default. Also double check requirements so you meet them.
I wasn't 100% sure if I was supposed to upload all of those files from the v8 folder.

I double checked the requirements and it looks like I exceed them.

I deleted the .htaccess file and it doesn't seem to be changing anything.

I appreciate your help by the way. Thank you very much.
Yes you need to replace all files after the admin upgrade.

Quote

Step 3
Once the database have been upgraded, copy all files and replace existing.


What host do you have?
I have bluehost.

-I uploaded the update from v7 to v8 folder and files.
-I upgraded the database
-After the database upgrade, the site looked completely different but still normal. My admin panel said it was updated to v8.
-I then uplaoded all the files from the "files" folder in the v8 download and then the site looks as it does in that screenshot.

I wonder what I'm doing wrong. :/
The upgrade should change default theme, unless you have a personal one set by profile. Your screenshot indicates that all files have not been uploaded or that some are missing.
Are you sure that all your current files has been replaced with the v8 pack files?
Also write your PHP & MySQL version, perhaps it can give a hint.
Upgrade from v7 to v8:
Upload files from upgrade folder. Go to the Administration> Upgrade and follow the instructions.
Than upload all v8 files.

Upgrade from v7/v8 to v9:
Upload all files, run yoursite.com/install.php (In title you can see PHP-Fusion Upgrade) and follow the instructions.

For v9 I recommend,
Rename old htdocss or public_html folder to old,
Upload new version then run installer. Don't forget, copy config.php file from old folder to new before run install.php. After that upload images and other stuff from old to new folder.

First method is easy and fast but you will have mixed up files from v7/v8 and v9.
I have reuploaded all files
I also manually changed the default theme to eshop through the database.

This is my server stats
Apache: 2.4.39
PHP: 7.2.16
MySQL: 5.6.41-84.1
Perl: 5.26.0

Now nothing is loading.

Merged on 04/07/2019:
As of right now I have it back to v7.02.07
I kept messing up so I restored all the original files and database.
I will try again when I get some more input from you guys.

Thanks for you help again. Maybe we can tackle this tomorrow. I hope so. I can't stay on v7 forever. Even v8 will need to be updated, right?

Could "multisite" have anything to do with it?
No multisite should not be an issue.
What did the error log show?
The error log doesn't show anything related to updates. Just various pictures missing from my album.

I actually installed a fresh v7 with a separate database and tried to update to v8 and the same thing happened. When I click update in the admin panel, it just goes blank.

Has this happened to anyone else?
songiuno has replied to this - 4 months ago
No, not that we know of, atm I have really no idea since there are no errors either. It has been tested in all Devs environments, on our test server, on local Laragon installs from PHP 7.1, PHP 7.2 > latest. etc etc.. So it is quite well tested as well.
Hmm this is so weird.

What would you suggest? It sounds like I need to hire someone or something?

How long will my up to date v7s last?

This is going to bother me until I Get it fixed.
This just happened to me today. I have two sites configured as multisites. The first site I did with relatively few problems, just minor tweaks but successfully upgraded from v7.02.07 to v8.00.21. I wrote down my exact steps to be sure I could backtrack if needed.

I attempted to upgrade the second site following the same steps I did for successful site 1, and after the upgrade and uploading all v8 files I get a blank page. I cannot figure out what might have been different. I'm now in the process of restoring v7.02.07 from backups.
I know how you feel, man. I'm not too savvy on PHP. I only know some basics. Maybe you'll give us some ideas and we will both benefit from it. Good luck!
songiuno has replied to this - 4 months ago
Me too. Last time I tinkered under the hood I was doing bare essential handcoding web pages in HTML4. I will post if I figure it out.
With no errors or apparent hiccups there are nothing to point us in the right direction to figure the mystery out. But was this second upgrade attempt done in same environment or on another server?
songiuno has replied to this - 4 months ago
Same environment, same server. The first upgrade was an install in the root of the domain. The second, failed, upgrade was on an install in a subdirectory of that same domain. I'm not sure if it being in a subfolder of the root as an install plays into this in any way. I would think not. However, I had also found in the past on v7.02.07 that certain infusions (photo widget panel for one) I could add on to the root install but could never get to run on the subdirectory install. I don't know if there's something inherently bad in installing below the root or if my specific subdirectory install of PHP-F was flawed in some way... or if all this is even related to the failed upgrade. I cannot find any deviation in the failed upgrade attempt yesterday from the successful install last weekend. I'm going to try again and see if the outcome is any different.
If you are using Chrome, right click anywhere in page and inspect element. It will fire up a developer console and you can see under Network tab, see any errors. If files missing it will report it.

For many years our users have been locked up with such issues upgrade and files server environment. The developers here will solve this soon by letting us doing the upgrade remotely. I have started the roadmap for it and hopefully we will see daylight in Babylon. That is if you opt in for Version 9 later.
songiuno has replied to this - 4 months ago
author Cupid
forumUpgrading issues - 8
replies24 posts
viewed575 times
activeLast updated on 4 months ago

Related

No other thread found.

Hot Questions

You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, songiuno, Chan, Cupid, RobiNN