Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Settings do not exist, please check your config.php file or run setup.php again.

Quote

Settings do not exist, please check your config.php file or run setup.php again.

Suddenly site does show this ... how to solve?

All files are present on the server - none are changed ... as far as I can see
@Helmuth, can you show me your site url. This happens because DB_SETTINGS could not be found.
siteurl: https://www.php-fusion.dk/
Check your phpMyAdmin if the tables are present, double check the config so nothing have changed, database paths, prefix etc. You are on A2 with that one so it is out of my control to look deeper.
Problem solved :-)

Some database tables had crashed...

Thanks to flj!
Today I have the same problem. How did you fix it?

Quote

Check your phpMyAdmin if the tables are present, double check the config so nothing have changed on your hosting side from an update, database paths, prefixes

Also, try to run a repair on settings table in phpmyadmin if all of the above is correct.
I've already solved the server-side problem - thanks
Don't scare me. We're already post Stable.
Unfortunately, I have this problem again. I haven't changed anything in the files and the problem has been since yesterday. I previously had a problem with the username I changed and it worked but now I have no idea why it doesn't work.
This is usually a hosting issue or as mentioned before, you might need to repair the table.

Quote

Check your phpMyAdmin if the tables are present, double check the config so nothing have changed on your hosting side from an update, database paths, prefixes
I have repaired the tables but still nothing.
Then it is one of the other, db user, db password or prefixes. Make sure your config.php match the user and pass and prefix set in your database config.
The config.php file is compatible with the user. Where in the database can I find this prefix from the config.php file
I'm using version 9.03.00
Do you have a copy of a old db_settings when the system worked?
If not, You can make a new install in a subdomain to your main domain.
Export db_settings and change to your domain & paths in the exported file, remember to also change the prefix to the old one.
Drop old db_settings and import the new db_settings that you have prepared.

Rob tells me that the issue can occur if your host upgrade the database handler, it may corrupt settings, so this is one way to solve it.
I also strongly recommend that you upgrade to latest 9 as well.
The problem was again corrected by the server.
Thread Information
Author
Replies
16 posts
Views
572 times
Last Post
Last updated on 6 days ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, helmuth, Chan, djdandi