Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.
Navigation

My update report from pf7 to pf8.00.21

Last updated on 2 years ago
Z
zizub
Posted 2 years ago
Updated the old site to version 8.00.21. This time everything went well. Now doing the settings.
1. How do I remove the space, the initial indent in the meta title?
2. How to turn off the blue screen with text? It appears when you first open the site.

Quote

Checking your browser...
Please enable JS and Cookies

What files to watch?
Edited by zizub on 13-07-2019 11:40, 2 years ago
zizub attached the following image:
empty_space.jpg blue_screen.jpg
Z
zizub
Posted 2 years ago
Well, with the title, I solved the question for myself. I had to abandon add_to and use set in order to customize the title so that at the very beginning the name of the published news or article was displayed. Now everything is good and there is no empty space at the very beginning. The question remains: how to turn off the blue background when the site first loads?
Blue screen prevents share in social networks. See the attached photo how my posts look in in facebook and vk.com social networks. Blue screen blocks photo display.
Edited by zizub on 13-07-2019 11:50, 2 years ago
zizub attached the following image:
fb.jpg vk.jpg
Z
zizub
Posted 2 years ago
I also have separate php pages for each news category. They contain meta tags:

Quote

set_title($locale['global_077c']);
set_meta("keywords", $locale['global_077ccc']);
set_meta("description", $locale['global_077cc']);

Set meta does not work for me.
Z
zizub
Posted 2 years ago
If you use the search on the site, then in the results you can see the exclamation mark in the black square. See the attached photo. I had a similar problem with the old panels for news and articles.
I changed the function

Quote

trimlink (stripslashes (strip_tags ($ data ['news_subject'])), 35)

Now it looks like this.

Quote

trim_text ($ data ['news_subject'], 35)

Now everything is fine in the panels, there are no more exclamation marks when cutting text.
Edited by zizub on 13-07-2019 18:34, 2 years ago
zizub attached the following image:
search_err.jpg
FalkFalk
Posted 2 years ago
Perhaps the blue message has to do with an addon? , I have never seen it my self.
Z
zizub
Posted 2 years ago
You were right. The cause of the appearance of the blue screen was a third-party plugin to protect against bots. I included it on the hosting when I changed the php version of the site, and then I forgot about it. Thanks for the advice. Now everything is all right. The site opens faster than before on pf-7. Thanks to all the developers for your work.
Edited by zizub on 16-07-2019 00:46, 2 years ago
Z
zizub
Posted 2 years ago
About the exclamation mark in the black square, in the search results for the site. I found a reason for myself. It's all about the obsolete function substr on line 210, in the file search.php https://github.com/PHPFusion/PHPFusio...h.php#L210 This function was originally written for single-byte encodings. There is also a difference in languages, for example, Russian letters are heavier than English, in bytes. For myself, I used mb_substr. It works on my hosting, but maybe not on all hosting. It would be more correct to use iconv_substr. Official sources say that the iconv extension is enabled by default in PHP. https://php.net/manual/en/iconv.insta...lation.php
Edited by zizub on 23-03-2020 20:17, 10 months ago
FalkFalk
Posted 2 years ago
Yes that is a good solution, great work!
Z
zizub
Posted 2 years ago
Possibilities of updating from the pf-8 version to the new pf-9 yet? I understand correctly?
FalkFalk
Posted 2 years ago
It should work, take a good copy first tho smile
Z
zizub
Posted 2 years ago
Well, I will try on XAMPP following the pf7 instructions to upgrade to the pf9 version. I also found the advice that RobiNN wrote in this thread: https://www.php-fusion.co.uk/infusion...d_id=39605

Quote

Replied by RobiNN, Apr 06, 2019.

Upgrade from v7/v8 to v9:
Upload all files, run yoursite.com/install.php (In title you can see PHPFusion Upgrade) and follow the instructions.

For v9 I recommend,
Rename old htdocss or public_html folder to old,
Upload new version then run installer. Don't forget, copy config.php file from old folder to new before run install.php. After that upload images and other stuff from old to new folder.

First method is easy and fast but you will have mixed up files from v7/v8 and v9.


The pf8 version works well for me. I just lack the Open Graph tags. I am pleased with everything, but the pf9 version is better than the version of pf7 and pf8.
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
You cannot set up a bounty in this discussion thread.
Moderator: Support Team
Users who participated in discussion: Falk, zizub,