Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Weblinks not working

I like the overall look of 9.03.40 but now have a problem with weblinks.

Directory is setup, went to add a link and it just sat there doing nothing. Checked the link outside of fusion and it worked fine. Can't remember where to look nor can I find if I asked this before....
All works fine.
If you adding link or something in PF wait few seconds. There is flood control.
RobiNN, I'm the only one using the site right now till I get it finished. That's what is bothering me. No error is coming up either...seems strange to me...Tried it both ways, from the weblinks menu as a site member and from the admin panel...no luck.
double check site settings so the path and urls is correct.
Every thing looks good on that front viewing site host settings in main settings panel, Falk....
I tried http, https, www and just domain on PHP-Fusion 9.03.40 I can not replicate this issue. Please attach a screen from your main settings of site path etc.
Some tips, have SQL port blank, make sure you run PDO and not MySQLI (config.php > $db_driver = 'pdo'; )
Checked config.php and it's set for pdo, attached is the "main Screen" screenshot. Thinking of diffusing and reinfusing. not much of a loss there....

www.frackemall.com/main.jpg
Everything looks correct, you can do a mysql dump if you have some links before defusing
Had no links, this was a complete install, not an upgrade...
Defused Weblinks, reinfused, added a directory without a problem, still no luck adding links. Click on Save or Save & Close nothing happens. Could the copy have been damaged during download?

This is where my headaches are :-)
www.frackemall.com/weblinks.jpg

I'll even grant admin privs to you or robiNN Falk if needed.
yes there could be a CRC error there, either on the DL or during the upload. Try Download a new pack and replace all files again.
That's the way I'm feeling Falk...Already got the new package and will upload shortly. Kinda funny that it's only the weblinks link add and not on the categories...
Falk, RobiNN.....

Re-Downloading and Reinstalling worked. Must have been a bad download/upload. No more weblinks problems.
Similar error for me on 2 test web pages but I found something interesting, please try this.

On my test website:
9.03.40 (fresh install approx. 1 month ago: 9.03.3 then upgrade to 9.03.40.)
config.php > $db_driver = 'pdo';
PHP: 7.2
SQL port: blank

Important:
In Admin->Weblinks->Setting->Required link description checked
AND
In Admin -> Settings -> Miscellaneous settings-> TinyMCE Editor enabled !!!

From front end with „Link submit” menu:
Chrome browser (80.0.3987.149): does not submit the link, nothing happens
Firefox browser (74.0): does not submit the link nothing happens, but after refreshing the page, you can submit a link.
(No errors in Error log.)

If "Required link description" unchecked in Weblink admin settings OR TinyMCE Editor disabled, submission is working well.

One more interesting thing:
Submitting an article works the same way, if TinyMCE Editor: enabled AND "Extended Article required": enabled .
Bonus error: if TinyMCE Editor enabled, in Admin-> Arcticle -> Add arcticle (or Submit Article from Front End) -> Snippet content -> BB code not working.

Maybe this could be a problem? TinyMCE Editor?

Another small problem is that the submitted link must be published first if I want to delete after submission,
because within "the article review function" delete button does not work.
But the behavior of the button depends on whether the link has a description or not.
If already published it can be deleted.
(I use Firefox browser mostly if that matters .)

(Moreover, Video infusion (from RobiNN) also doesn't send video link but i'm still trying to see what the problem is. But this is another topic.)
fixed
That's what it was Vito. TinyMCE. Thanks
Thread Information
Author
Replies
16 posts
Views
151 times
Last Post
Last updated on 9 days ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, RobiNN, ViZo, daimonbok1