Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

Language switch not working after update

I update my site from 9.03.5 to 9.03.6.

My default language works (hungarian), but if i try to switch language to english (on main site or admin site) language remain local language and an error message is displayed:
https://pitzklan.hu/site/viewpage.php...ng=English
Top of the site: "Warning: A non-numeric value encountered in ......./site/maincore.php on line 223"
Error log: "PHP Warning: A non-numeric value encountered in ......../site/maincore.php on line 223"
(PHP ver.: 7.2.31)

I copied back maincore.php from v9.03.5 and it works.

I can see the difference between the two files, but I don't know what's wrong with the new one.
......./site/maincore.php on line 223

Quote

if ($_get_lang && file_exists(LOCALE.+$_get_lang."/global.php"wink && in_array($_get_lang, $enabled_languages)) {


change

Quote

if ($_get_lang && file_exists(LOCALE.$_get_lang."/global.php"wink && in_array($_get_lang, $enabled_languages)) {
Thanks, it works.

(Köszönöm Karrak, azt hittem el vagy veszve de úgy látom azért figyelemmel kíséred az eseményeket. :-) )
Thread Information
Author
Replies
3 posts
Views
90 times
Last Post
Last updated on 1 month ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: karrak, ViZo