Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.
Sign In
Not a member yet? Click here to register.

'Funny' FAQ after upgrade to 9.03.80

Don't know if this is the right category - it could also be 'Suspected bugs and errors'.

After the upgrade the FAQ section looks 'funny' - neither links nor images are shown correctly

Has the upgrade stripped anything?

I also tried to add a new FAQ - same result :-(

How to solve?
helmuth attached the following image:
jc-faq-error.png
The {%closetable%} at bottom suggest that FaQ have not been replaced with a full new version. Try to upload all files for the FaQ from the latest pack.
 
Deleted FAQ on the server, reuploaded the FAQ folder from the latest download package including Danish language files

Same result :-(
Try to re-save. Click Edit and then save. I didn't find any problem.
This is the code I insert:

Quote

En indbygget funktion i hjemmesidens CMS er, at man kan sende private beskeder til hinanden.

<img src="https://joyfulchoir.dk/images/js-pb.png" alt="" class="img-responsive"/>

1, 2 og 3 angiver hvor mange beskeder der i boksene. Klik på <b>Private beskeder</b>
Derefter på <b>Ny besked</b>. I modtager-feltet kan man søge/sortere ved at indtaste fx a, b osv.

<img src="https://joyfulchoir.dk/images/js-nypb.png" alt="" class="img-responsive"/>

Modtageren vælges så ved at klikke på navnet.

<img src="https://joyfulchoir.dk/images/js-nypb2.png" alt="" class="img-responsive"/>

En besked kan fx se således ud:

<img src="https://joyfulchoir.dk/images/pm-besked.png" alt="" class="img-responsive"/>

Det skal understreges, at det KUN er afsender og modtager, der kan læse indholdet af disse beskeder. Skulle man være så heldig at have administrator-rettigheder på hjemmesiden, vil man yderligere kunne sende beskeder til grupper og ikke kun enkeltpersoner.


After saving/resaving the result is this:

Quote

En indbygget funktion i hjemmesidens CMS er, at man kan sende private beskeder til hinanden.

img src=https://joyfulchoir.dk/images/js-pb.png alt= class=img-responsive/

1, 2 og 3 angiver hvor mange beskeder der i boksene. Klik på bPrivate beskeder/b
Derefter på bNy besked/b. I modtager-feltet kan man søge/sortere ved at indtaste fx a, b osv.

img src=https://joyfulchoir.dk/images/js-nypb.png alt= class=img-responsive/

Modtageren vælges så ved at klikke på navnet.

img src=https://joyfulchoir.dk/images/js-nypb2.png alt= class=img-responsive/

En besked kan fx se således ud:

img src=https://joyfulchoir.dk/images/pm-besked.png alt= class=img-responsive/

Det skal understreges, at det KUN er afsender og modtager, der kan læse indholdet af disse beskeder. Skulle man være så heldig at have administrator-rettigheder på hjemmesiden, vil man yderligere kunne sende beskeder til grupper og ikke kun enkeltpersoner.


ALL links and attributes are stripped in the saving process :-(
I tried it on our demos and again no problem found. https://v9.demos.php-fusion.co.uk/

Maybe files in includes are not updated.
What specific files do you mean in includes?

As far as I can see files in the includes folder ARE updated ...
Best practise when we get wierd hiccups is to download a new copy of latest and reupload all files. Can be CRC errors in zip etc etc.

 
New download downloaded

ALL files reuploaded

Logged out of site

Logged in again

NO change in the way the FAQ admin strips/changes link tags :-(

See for yourself: https://joyfulchoir.dk/frequently-asked-questions/category/1
So very odd indeed, We tested on multiple locations now and just can´t reproduce the issue. Try to remove includes directory and replace it from the new pack. Could some some remains that has been mixed and still auto include since you had a very old version.
 
Chan checked your site and realized we had a issue there when php_exe is enabled. This have been fixed on your side and everything should work as expected now.
The issue have been patched for next version : https://github.com/php-fusion/PHP-Fusion/commit/e603925e2ba94d5b36e093d939786ce94b880c43
Yes, things are OK now ... thanx for helping out :-)
Thread Information
Author
Replies
12 posts
Views
151 times
Last Post
Last updated on 7 days ago
You can view all discussion threads in this forum.
You cannot set up a bounty in this discussion thread.
You can start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
You cannot up or down-vote on the post in this discussion thread.
Users who participated in discussion: Falk, helmuth, RobiNN